Excelproblem Mittelwert und Bedingung

20/05/2008 - 21:08 von Kai Apel | Report spam
Liebe NG

Ich möchte von einer Spalte den Mittelwert berechnen, dazu habe ich
mir auf einem anderen Tabellenblatt den Wert definiert, nachdem in der
Liste gesucht werden soll. Dazu kann es passieren das als Wert in der
entsprechenden Wertespalte auch ein "-" steht. Meines Erachtens sollte
das aber ignoriert werden. Aber irgendwie klappt es nicht.

MITTELWERT(WENN((Data!J2:J28='Gültige Werte'!B25);Data!L2:L28))

Alternativ mache ich das mit:

=(SUMMEWENN(Data!$J$2:Data!$J$6000;'Gültige Werte'!$B25;Data!$L$2:$L
$6000))/ZÄHLENWENN(Data!$J$2:Data!$J$6000;'Gültige Werte'!$B25)

mit folgenden Angaben:
Data!$J$2:Data!$J$6000 - ist die Spalte des Suchkriteriums
'Gültige Werte'!$B25 - ist der Wert, nach dem gesucht werden soll
Data!$L$2:$L$6000 - ist die Spalte mit den Zahlenwerten, von denen ich
den Mittelwert benötige

in der in der "Zàhlenwenn"-Funktion werden ja leider auch die Zellen
gezàhlt, in denen ein "-" vorkommt.
Kann mir jemand Hilfestellung geben?

Kai Apel
 

Lesen sie die antworten

#1 Kai Apel
21/05/2008 - 11:08 | Warnen spam
naja, meine Schuld, wer lesen kann ist klar im Vorteil - die
Mittelwertfunktion zàhlt Felder in denen "-" enthalten ist nicht mit:
=MITTELWERT(WENN((Data!$J$2:$J$6000='Gültige Werte'!$B27);Data!$O$2:$O
$6000))

Kai

Ähnliche fragen