Forums Neueste Beiträge
 

Excelstart nur bei einer bestimmten Rechner/User-Kombi langsam

30/03/2010 - 16:00 von arno.nym | Report spam
Hallo zusammen.
Ich bin faul und habe den Inhalt (den schon woanders gepostet habe) einfach
hier herein kopiert, da ich bis jetz keine Lösung
erhlaten/gefunden/erfolgreich probiert habe.
Zum Problem:
User x startet die Tabelle (vmt. eine 2003er, evt. noch àlter), es werden
aus div. Quellen Daten aus (ich vermute) Textdateien importiert und stehen
nach ca 5-8 Sekunden (P4 mit 3GHz und 1024 MB RAM) parat.
User y startet genau die gleiche Verknüpfung und wartet und wartet und
wartet... ca 4 Minuten lang. Der PC ist dabei zu ca 50% ausgelastet (und
baugleich zum vorher genannten).
Dabei sieht man, dass div. Textdateien aufgerufen werden (daher meine
Vermutung) und das Office im Kompatibilitàtsmodus làuft (nach meinen
Recherchen ist das aber in Ordnung, da es sich ja um eine 2003er(?!?) Tabelle
handelt).

Wenn sich jetzt der Benutzer x (ohne das Problem) am PC von User y (mit dem
Problem) anmeldet, sich zur im Netzwerk liegenden Resource begibt, die
Tabelle startet dauert es nur 5 Sekunden und die Tabelle ist importiert
Ich hatte gestern noch einen zur Aufbereitung bei mir befindlichen PC zur
Domànenanmeldung testweise mit den Daten von Y gefüttert, auch hier dauert
der Start nur gestoppte 8-9 Sekunden.
Ich habe schon die Benutzerrechte angepasst/kontrolliert in der Domàne, es
hat nichts gebracht.

Es MUSS an der Kombination Benutzer y mit den lokal auf dem PC befindlichen
Excel-Einstellungen liegen (es handelt sich bei beiden genannten Versionen um
Office 2007 SBS SP2), diese müssen anders sein, als bei allen anderen (es
gibt ca 8 Benutzer, die die Tabelle nutzen und nur y hat dieses Problem).

Zu installierten Add-Ins :
User y (mit den Problemen) und x (ohne Probleme) haben gemeinsam:
Analyse-Funktion, Analyse-Funktion VBA, Ausgeblendete Arbeitsblàtter, Zeilen
und Spalten, Benutzerdefinierte XML-Dateien,Datum (Smarttaglisten),
Internet-Assistent VBA, Kopf- und Fußzeilen, Nachschlage-Assistent, nicht
sichtbarer Inhalt, Personennamen, Solver und Teilsummen-Assistent.

User y (Mit Problemen) hat "exklusiv";
Eurowàhrungstool

ich habe noch ein paar Zugaben zu machen:
- Der Fehler fing (laut der Userin) damit an, dass der Start der Tabelle
ungewöhnlich lange dauerte, sie dachte, Excel wàre abgestürzt und hat es
(vermute ich) beendet.
Als ich mir das Problem anguckte bemerkte ich folgenden Fehler (Aus
Microsoft Visual Basic):
Laufzeitfehler 1004, die Methode "openText" für das Objekt "WorkBooks" ist
fehlgeschlagen.
Anschliessend hatte man mehrere Dateien zum abspeichern zur Auswahl, ich
habe wissentlich nichts gespeichert, vielleicht meine Userin. So oder so
würde ich aber meine Hand dafür nicht ins Feuer legen.
Nàchster Fehler, ebenfalls aus Visual Basic:
Laufzeitfehler 1004, auf die Datei konnte nicht zugegriffen werden.
Versuchen Sie die folgenden Lösungsvorschlàge:
- Überprüfen Sie, ob der angegebene Ordner vorhanden ist.
- Stellen Sie sicher, dass der Ordner, in dem sich die Datei befindet, nicht
schreibgeschützt ist.
- Vergewissren Sie sich, dass der Dateiname keines der folgenden Zeichen
enthàt:

<?[]: Dateiname.txt oder *


Der Dateiname darf nicht lànger als 218 Zeichen sein...

Da ich mit dem Datenimport nicht wirklich zurande komme, kann ich das nicht
wirklich überprüfen, da aber alle anderen User keine Problem mit der Tabelle
haben, gehe ich realistisch davon aus, dass sich hier wirklich nichts
geàndert hat.
Nachdem ich (nichts) abgespreichert habe, komen diese Fehlermeldungen auch
nicht mehr.

Vielen Dank

Carsten
 

Lesen sie die antworten

#1 Bernhard Sander
30/03/2010 - 16:37 | Warnen spam
Hallo Carsten,

Ich bin faul und habe den Inhalt (den schon woanders gepostet habe) einfach
hier herein kopiert, da ich bis jetz keine Lösung
erhlaten/gefunden/erfolgreich probiert habe.
Zum Problem:


Prüfe mal die Vernetzungshardware (Netzwerkkarte, Kabel, Switch, WLAN...)

Gruß
Bernhard Sander

Ähnliche fragen