Exch2007, Win2008 & Push Dienst

04/05/2008 - 01:51 von MBeier | Report spam
Hallo!
Direct Push hat ja mit Exch2003 super funktioniert und nun habe ich mich der
neuen Herausforderung gestellt es mit Exch2007 zu probieren.
Nach der Standardinstallation mit Win2008 und Exch2007 (beide 64bit)
funktioniert soweit alles mit OWA & SSL. Nun scheint OWA beim Exch2007 nicht
mehr auf server/exchange zu hören, sondern es funktioniert standardmàßig nur
mit server/owa.
Die Windows Mobile Smartphones probieren es aber anscheind nur mit /exchange.
Wie kann ich den Win2008 im IIS-Manager dazu bringen auch auf /exchange zu
reagieren? Wenn man im Smartphone die Synchronisierung konfiguriert und die
OWA-URL eingibt, wird aus https://server-url/owa immer server-url (ohne
https:// und /owa). Bei der Synchronisierung kommt dann die Fehlermeldung,
dass der Server nicht reagiert. Wenn ich im Smartphonebrowser die OWA-Seite
mit /owa öffne, funktioniert es super.
Gibt es irgendwo ein DirectPush HowTo für Win2008, Exch2007 ???
Habe leider nichts dazu gefunden.

Vielen Dank, Marcus
 

Lesen sie die antworten

#1 Frank Röder [MVP]
04/05/2008 - 10:33 | Warnen spam
Hallo Marcus,

eigentlich geht das mit e2k7 noch viel einfacher, denn Du musst nicht
mehr an der Registry usw. fummeln.

Direct Push hat ja mit Exch2003 super funktioniert und nun habe ich
mich der
neuen Herausforderung gestellt es mit Exch2007 zu probieren.
Nach der Standardinstallation mit Win2008 und Exch2007 (beide 64bit)
funktioniert soweit alles mit OWA & SSL. Nun scheint OWA beim
Exch2007 nicht
mehr auf server/exchange zu hören, sondern es funktioniert
standardmàßig nur
mit server/owa.



was hast Du denn für ein Zertifikat im Einsatz? Setzt Du ein
öffentliches Zertifikat ein? Vertraut das Smartphone der ausstellenden
Zertifizierungsstelle?

Die Windows Mobile Smartphones probieren es aber anscheind nur mit
/exchange.
Wie kann ich den Win2008 im IIS-Manager dazu bringen auch auf
/exchange zu
reagieren? Wenn man im Smartphone die Synchronisierung konfiguriert
und die
OWA-URL eingibt, wird aus https://server-url/owa immer server-url
(ohne
https:// und /owa). Bei der Synchronisierung kommt dann die
Fehlermeldung,



Auf dem Smartphone musst Du bei der Active Sync Einrichtung nur den
FQDN des Servers angeben, so wie er über das Internet erreichbar ist.

dass der Server nicht reagiert. Wenn ich im Smartphonebrowser die
OWA-Seite
mit /owa öffne, funktioniert es super.
Gibt es irgendwo ein DirectPush HowTo für Win2008, Exch2007 ???
Habe leider nichts dazu gefunden.



Überprüfe mal in den Logfiles des IIS ob das Smartphone es überhaupt
versucht. Dort kannst du dann auch sehen, warum der Verbindungsversuch
vom IIS abgelehnt wird. Ist bei den Postfàchern auch das Active Sync
erlaubt? Poste auch mal die Ausgabe von "get-activesyncvirtualdirectory
| fl".


Viele Grüße
Frank Röder
MVP Windows Server System - Directory Services
"Ex oriente lux"

Ähnliche fragen