Exchange 07-Problem: Active Sync mit Clientzertifikaten funktioniert nicht

19/06/2008 - 12:28 von Herbert Ochsenblut | Report spam
Hallo zusammen,

ich versuche unter Win2k8 mit Exchange 07 und IIS 7 Exchange Active Sync mit
Clientzertifikaten zum Laufen zu bringen:

Ohne Clientzertifikate funktioniert der Sync über WinMobile Active Sync per
Smartphone problemlos.

Nun habe ich eine CA eingerichtet, Userzertifikate erstellt, diese in der
AD-Verwaltung an die User gebunden, im Exchange bei ActiveSync
"Clientzertifikate erfordern" aktiviert und in der IIS Konfig bei der
ActiveSync Unterwebsite "clientCertificateMappingAuthentication" auf True
gesetzt.

Allerdings funktioniert das nicht richtig:
Auf den WinMobile Geràten sind die PFX Zertfikate eingerichtet, mit CA
etc... allerdings erhalte ich beim Sync MIT Clientzertifikat immmer wieder
die Aufforderung, das PW am Smartphone einzugeben, was ich tue, aber nach
ein paar, Sekunden kommt die AUfforderung wieder.

Schalte ich Clientzertfikate beim Server wieder ab, funktioniert alles
wieder prima.

Hat jemand eine Idee?

Irgendetwas scheint mit den Zertifikaten nicht zu stimmen.
Sind alle von meiner eigenen CA und sowohl am Server als auch auf dem
WinMobile Geràt trusted, also CA ist importiert.
 

Lesen sie die antworten

#1 Herbert Ochsenblut
19/06/2008 - 14:06 | Warnen spam
Update:

Wenn ich die Option: clientCertificateMappingAuthentication auf False setzt
im IIS, dann fragt er immer noch 2x nach den Login Daten in AS beim Sync,
aber dann synchronisiert er mit Client-Zertifikaten.
Wie kann ich das erneute PW Nachfragen verhindern?
PW speichern ist natürlich immer aktiviert...

Ähnliche fragen