Exchange 2003 Event ID 7004 x-exps & 5.7.1 Unable to relay

02/09/2008 - 14:24 von susanne | Report spam
Hallo

Wir haben ein ganz komisches Fànomen auf einem unserer Exchange
2003-Servern, das sporadisch immer wieder auftaucht, im Moment eher
heftig, weshalb ich auch schreibe.

Es gibt einen FrontEnd Server FE-1 (die untenstehende x-IP-Adresse
entspricht ihm), er steht in der DMZ sowie zwei Backend-Server BE-1
und BE-2.
SP2 ist drauf, das Betriebssystem ist Windos 2003 SP1. Virenscanner
ist Sophos Antivirus 7.x auf allen Servern sowie PureMessage Version
2.6.1 auch von Sophos auf BE-1 & BE-2.

Das Ganze làuft seit mehreren Jahren einigermassen stabil, wie ich
jedoch festgestellt habe im Nachhinein, ist dieses Fehler-Combo so
alle paar Monate ganz sporadisch und jeweils einmalig aufgetaucht.
Wird das Mail dann nochmals versendet, funktionierts meistens.


Event Type: Error
Event Source: MSExchangeTransport
Event Category: SMTP Protocol
Event ID: 7004
Date: 02.09.2008
Time: 10:44:13
User: N/A
Computer: BE-1
Description:
This is an SMTP protocol error log for virtual server ID 1, connection
#1. The remote host "x.x.x.x", responded to the SMTP command "x-exps"
with "535". The full command sent was "X-EXPS
". This will probably cause the connection to fail.


Darauf folgt eine, zwei oder bei ganz schlechter Laune des Servers ein
ganzer Büschel des folgenden Fehlers, wobei die Mails an
unterschiedliche Personen adressiert sind.

Event Type: Error
Event Source: MSExchangeTransport
Event Category: SMTP Protocol
Event ID: 7004
Date: 02.09.2008
Time: 10:44:13
User: N/A
Computer: BE-1
Description:
This is an SMTP protocol error log for virtual server ID 1, connection
#1. The remote host "x.x.x.x", responded to the SMTP command "rcpt"
with "550 5.7.1 Unable to relay for name@domaene.ch ". The full
command sent was "RCPT TO:<name@domaene.ch> ". This will probably
cause the connection to fail.


Die versendende Person bekommt folgende Antwort beim Versenden eines
Mails (die meisten sind über Mapi angeschlossen)

Ihre Nachricht hat einige oder alle Empfànger nicht erreicht.
Betreff: AW: E-Mail Adresse von xy
Gesendet am: 01.09.2008 08:35

Folgende Empfànger konnten nicht erreicht werden:
'name' am 01.09.2008 08:36
Sie sind nicht berechtigt, Nachrichten an diesen Empfànger zu
senden. Wenden Sie sich an den Systemadministrator.

<BE-1.local #5.7.1 smtp;550 5.7.1 Unable to relay for name@domaene.ch>


Weder beim FE-1 noch dem BE-2 zeigen sich Fehlermeldungen im
Event-Log.

Wenn der Server grad wieder "Büschel-Zeit" hat, d.h. keine Mails mehr
durchlàsst sondern alle Mai dann hilft nur noch ein Reboot. Danach
làufts wieder eine Weile ok. Letzte Woche war ein Reboot nötig und nun
eine Woche spàter wieder.
Jetzt ist nur noch die Frage, weshalb das ganze Problem immer wieder
sporadisch auftaucht.

Unter Google/Microsoft/Sophos habe ich diverses abgeklappert, aber bin
auf keine Lösung gestossen, die unserer Situation àhnlich ist.
Der FQDN ist korrekt eingestellt.
Die Authentifizierungseinstellungen sind ok.
Jeder Server hat nur eine virtuelle SMTP-Queue.

Was ist dein Vorschlag?

Danke
Susanne
 

Lesen sie die antworten

#1 Walter Steinsdorfer [MVP]
02/09/2008 - 22:40 | Warnen spam
Hallo Susanne,

Wir haben ein ganz komisches Fànomen auf einem unserer Exchange
2003-Servern, das sporadisch immer wieder auftaucht, im Moment eher
heftig, weshalb ich auch schreibe.

Es gibt einen FrontEnd Server FE-1 (die untenstehende x-IP-Adresse
entspricht ihm), er steht in der DMZ sowie zwei Backend-Server BE-1
und BE-2.



leider ein paar Gegenfragen: Wenn der FE-1 in der DMZ steht, wie spricht er
denn dann mit den Backend-Servern? Als Protokoll wird da RPC verwendet, wenn
ihr das durch die Firewall bringen wollt könnt ihr die auch gleich
ausschalten. Ist / Sind die Backend-Server Cluster oder 2
Single-Exchange-Server?

SP2 ist drauf, das Betriebssystem ist Windos 2003 SP1.



Warum nicht W2k3 Service Pack 2? Ist schon eine Weile verfügbar.

Virenscanner
ist Sophos Antivirus 7.x auf allen Servern sowie PureMessage Version
2.6.1 auch von Sophos auf BE-1 & BE-2.



Ist der Virenscanner so eingestellt das die Exchange-Verzeichnisse nicht
angefasst werden? Die Datenbanken und Smtp_Verzeichnisse dürfen nur per
Sink/Api gescannt werden.


Das Ganze làuft seit mehreren Jahren einigermassen stabil, wie ich
jedoch festgestellt habe im Nachhinein, ist dieses Fehler-Combo so
alle paar Monate ganz sporadisch und jeweils einmalig aufgetaucht.
Wird das Mail dann nochmals versendet, funktionierts meistens.


Event Type: Error
Event Source: MSExchangeTransport
Event Category: SMTP Protocol
Event ID: 7004
Date: 02.09.2008
Time: 10:44:13
User: N/A
Computer: BE-1
Description:
This is an SMTP protocol error log for virtual server ID 1, connection
#1. The remote host "x.x.x.x", responded to the SMTP command "x-exps"
with "535". The full command sent was "X-EXPS
". This will probably cause the connection to fail.




das Problem (und hoffentlich auch das nachfolgende) wird hiermit gelöst:

Exchange Protocol Security authentication fails after you install Windows
Server 2003 Service Pack 1 on a server that has multiple SMTP virtual
servers in Exchange Server 2003
http://support.microsoft.com/kb/914137/en-us

Falls du da nicht "multiple SMTP virtual SErvers" siehst könnte es durchaus
auch an dem liegen was unter "Cause" steht.

Viel Glück, wenn das nichts hilft rühr dich wieder.


Darauf folgt eine, zwei oder bei ganz schlechter Laune des Servers ein
ganzer Büschel des folgenden Fehlers, wobei die Mails an
unterschiedliche Personen adressiert sind.



die so menschlich ;-).

Viele Grüsse aus München

Walter Steinsdorfer
MVP Exchange Server

Ähnliche fragen