Exchange 2003 ist sehr langsam (geworden)

17/05/2010 - 10:12 von Marc Westphal | Report spam
Hallo liebe Leute, ich habe ein Problem mit unserem Exchange-Server.Umgebung:
2 DCs mit Windows Server 2003, 1 Exchange Server 2003 (x32) auf einem Windows
Server 2003 (alles inkl. Updates). Der Exchange Server ist "auf einmal",
quasi über Nacht, sehr langsam geworden. Es wurde keinerlei Änderungen an
Hard- oder Software vorgenommen.Der Best Practive Analyser gibt (wie gewohnt)
lediglich als Fehler aus, dass die Werte für ein- und ausgehende Nachrichten
zu hoch eingestellt sind, das hat er aber schon immer ausgegeben.Die Probleme
betreffen im Kern drei Auswirkungen: Mails bleiben auf dem Server in der
Warteschlange hàngen (aber eben nicht immer, sondern immer öfter), werden
aber innerhalb von ein paar Stunden "irgendwann" zugestellt, im Outlook
(2007) bleiben die Mails sehr lange im "Postausgang" und das Durchsuchen von
mehreren Postfàchern dauert bis zu 15 Minuten, bis etwas passiert.Sehr lange
im Postausgang definiert, dass man vorher quasi nur für einen Augenblick
gesehen hat, dass etwas im Postausgang ist, jetzt kann man es ca. 45 Sekunden
beobachten.Als Virenscanner làuft "Symantec Mail Security für Exchange", aber
die Software làuft auch schon seit einiger Zeit, bevor die Probleme
auftraten.Es gibt de facto keinerlei Fehlermeldungen in den Ereignisanzeigen
oder Hinweise, dass etwas nicht richtig funktioniert. Gibt es eine Art
Verfahren, welches als Standard gilt, wenn so etwas auftritt, um dieses
Problem zu beheben? Gelesen habe ich über das Defragmentieren der Datenbank
mit eseutil.exe, jedoch wurden solche Vorgehensweisen auch immer mit
"Vorsicht" betitelt, da diese Aktion, wenn man es nicht richtig macht, auch
"in die Hose gehen kann".Die Datenbank ist momentan rund 48 GB groß bei noch
freiem Plattenplatz von rund 70GB, es sind ca. 50 User mit dem Server
verbunden. Die Serverhardware ist aktuell, es sind lediglich nur 4 GB RAM,
die Exchange bzw. dem OS zur Verfügung stehen. Ich bin für jeden Hinweis
dankbar und bedanke mich im Voraus für Eure Mühe. Viele Grüße Marc Westphal
 

Lesen sie die antworten

#1 Tobias Redelberger [MVP - SBS]
17/05/2010 - 11:58 | Warnen spam
Hi Marc,

Hallo liebe Leute, ich habe ein Problem mit unserem
Exchange-Server.Umgebung:
2 DCs mit Windows Server 2003, 1 Exchange Server 2003 (x32) auf einem
Windows
Server 2003 (alles inkl. Updates). Der Exchange Server ist "auf einmal",
quasi über Nacht, sehr langsam geworden. Es wurde keinerlei Änderungen an
Hard- oder Software vorgenommen.Der Best Practive Analyser gibt (wie
gewohnt)
lediglich als Fehler aus, dass die Werte für ein- und ausgehende
Nachrichten
zu hoch eingestellt sind, das hat er aber schon immer ausgegeben.Die
Probleme
betreffen im Kern drei Auswirkungen: Mails bleiben auf dem Server in der
Warteschlange hàngen (aber eben nicht immer, sondern immer öfter), werden
aber innerhalb von ein paar Stunden "irgendwann" zugestellt, im Outlook
(2007) bleiben die Mails sehr lange im "Postausgang" und das Durchsuchen
von
mehreren Postfàchern dauert bis zu 15 Minuten, bis etwas passiert.Sehr
lange
im Postausgang definiert, dass man vorher quasi nur für einen Augenblick
gesehen hat, dass etwas im Postausgang ist, jetzt kann man es ca. 45
Sekunden
beobachten.Als Virenscanner làuft "Symantec Mail Security für Exchange",
aber
die Software làuft auch schon seit einiger Zeit, bevor die Probleme
auftraten.Es gibt de facto keinerlei Fehlermeldungen in den
Ereignisanzeigen
oder Hinweise, dass etwas nicht richtig funktioniert. Gibt es eine Art
Verfahren, welches als Standard gilt, wenn so etwas auftritt, um dieses
Problem zu beheben? Gelesen habe ich über das Defragmentieren der
Datenbank
mit eseutil.exe, jedoch wurden solche Vorgehensweisen auch immer mit
"Vorsicht" betitelt, da diese Aktion, wenn man es nicht richtig macht,
auch
"in die Hose gehen kann".Die Datenbank ist momentan rund 48 GB groß bei
noch
freiem Plattenplatz von rund 70GB, es sind ca. 50 User mit dem Server
verbunden. Die Serverhardware ist aktuell, es sind lediglich nur 4 GB RAM,
die Exchange bzw. dem OS zur Verfügung stehen. Ich bin für jeden Hinweis
dankbar und bedanke mich im Voraus für Eure Mühe.



das "standardisierte" Verfahren dazu lauter:

Erst einmal der Ursache auf die Spur zu kommen, um dann daraus Schlüsse auf
eine mögliche Lösung zu eruieren.

Blanker Aktionismus bringt hier nichts und kann auch schnell mal ins
Gegenteil umschlagen.

Deshalb: Mittel Performance-Monitor den Flaschenhals (zu wenig RAM,
Festplatten fragmentiert, Storage-Kontroller überlastet bzw. in Restore-Mode
oder Schreibcache wegen fehlender Batterie(defekt) abgeschàlten, defekte
Festplatten, veraltete Netzwerktreiber, -kabel, Fehlerhafter Switchport
usw.) herausfinden und dann ggf. noch einmal die exakten Ursachen posten.

Wir können hier über die Neswgroup nicht erraten, was der Server hat. Und
nein, stundelanges hin und her posten möglicher Ansàtze bringt auch nichts.

Ausschliesslich eine Vor-Ort Analyse bringt weitere Aufschlüsse.

Tobias Redelberger
StarNET Services (HomeOffice)
Frankfurter Allee 193
D-10365 Berlin
Tel: +49 (30) 86 87 02 678
Mobil: +49 (163) 84 74 421
Email:
Web: http://www.starnet-services.net

Ähnliche fragen