externe Daten importieren - Formelverlust

02/09/2008 - 16:29 von Jonas | Report spam
Hallo zusammen,

Mein Problem besteht darin das ich von MS Access Daten importiere in Excel.
Ich habe eine große DB die ich durch abfragen speziell gefiltert habe, diese
Abfragen habe ich nun in Excel importiert.
Mein Problem besteht darin das ich in Excel schon formln neben die
importierten Daten reingeschieben habe, und der Zellenbezug nach dem Import
nicht mehr übereinstimmt.
Ich muss einige Daten auswerten und kann deshalb nicht die Formeln immer
wieder neu eingeben bzw verbessern.

Als Beispiel:
Meine Spalte Q hat folgende Formeln:

=WENN($C2>0;1;0)
=WENN($C3>0;1;0)
=WENN($C4>0;1;0)
=WENN($C5>0;1;0)
=WENN($C6>0;1;0)
usw.

wenn man nun die Daten importiert passiert folgendes:

=WENN($C2>0;1;0)
=WENN($C19>0;1;0)
=WENN($C20>0;1;0)
=WENN($C21>0;1;0)
=WENN($C22>0;1;0)

Ich weiß nicht wie ich das Problem beheben kann und wàre über Hilfe sehr
erfreut. ;)
 

Lesen sie die antworten

#1 Thomas Ramel
03/09/2008 - 06:59 | Warnen spam
Grüezi Jonas

Jonas schrieb am 02.09.2008

Mein Problem besteht darin das ich in Excel schon formln neben die
importierten Daten reingeschieben habe, und der Zellenbezug nach dem Import
nicht mehr übereinstimmt.
Ich muss einige Daten auswerten und kann deshalb nicht die Formeln immer
wieder neu eingeben bzw verbessern.

Als Beispiel:
Meine Spalte Q hat folgende Formeln:

=WENN($C2>0;1;0)
=WENN($C3>0;1;0)
=WENN($C4>0;1;0)
=WENN($C5>0;1;0)
=WENN($C6>0;1;0)
usw.

wenn man nun die Daten importiert passiert folgendes:

=WENN($C2>0;1;0)
=WENN($C19>0;1;0)
=WENN($C20>0;1;0)
=WENN($C21>0;1;0)
=WENN($C22>0;1;0)



Beim Aktualisieren der Abfrage werden die nicht mehr zutreffenden Zeilen im
Datenbereich gelöscht und die anderen rücken auf.

Passe deine Formeln wie folgt an, dann müsste es klappen:

Q2 =WENN(INDIREKT("$C"&ZEILE())>0;1;0)



Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Win XP Pro SP-2 / xl2003 SP-3]
Microsoft Excel - Die ExpertenTipps

Ähnliche fragen