Externes USB-Audiointerface verzerrt nach einer Stunde

09/09/2012 - 08:32 von Holger Marzen | Report spam
Ich habe ein m-audio Fasttrack Pro am USB hàngen, und es funktioniert
sowohl unter ALSA als auch unter Jack. Allerdings nur eine Zeit lang
(Größenordnung eine bis zwei Stunden), dann wird der Sound verzerrt.
Wenn ich Jack neustarte, funktioniert der Start erst nicht, dann beim
zweiten Versuch ist meist alles wieder ok für eine gewisse Zeit. Ich
muss das m-audio NICHT aus-/einschalten.

Ein weiteres USB-Interface habe ich leider nicht zum Testen.

Wenn ich das Interface gleich per ALSA-Clients ansteuere, passiert das
nicht. Ich nehme an, jeder ALSA-Client macht seinen eigenen "open"-Call,
wàhrend Jack ein einziges Mal die Karte eröffnet.

Gibt es bekannte Probleme mit dem USB-Sound unter Linux? Ich nutze
Kernel 3.0. Den 3.2 kann ich nicht nutzen, weil VirtualBox damit üble
Fehler produziert.
 

Lesen sie die antworten

#1 Dirk Thierbach
09/09/2012 - 10:44 | Warnen spam
Holger Marzen wrote:
Ich habe ein m-audio Fasttrack Pro am USB hàngen, und es funktioniert
sowohl unter ALSA als auch unter Jack. Allerdings nur eine Zeit lang
(Größenordnung eine bis zwei Stunden), dann wird der Sound verzerrt.
Wenn ich Jack neustarte, funktioniert der Start erst nicht,



Was heisst "Start funktioniert nicht"?

dann beim zweiten Versuch ist meist alles wieder ok für eine gewisse
Zeit. Ich muss das m-audio NICHT aus-/einschalten.



Schuss ins Blaue: Ueberlauf irgendeines internen Zaehlers.

Wenn ich das Interface gleich per ALSA-Clients ansteuere, passiert das
nicht. Ich nehme an, jeder ALSA-Client macht seinen eigenen "open"-Call,
wàhrend Jack ein einziges Mal die Karte eröffnet.



Was passiert, wenn Du das Interface ueber einen ALSA-Klienten fuer
laengere Zeit (die mehreren Stunden, bis es Probleme gibt) dauernd
ansteuerst? Wenn nichts passiert, liegt es an Jack. Wenn da auch etwas
passiert, liegt es an ALSA. Dann weiss man zumindest besser, wo man
suchen muss.

Gibt es bekannte Probleme mit dem USB-Sound unter Linux?



Mir sind keine bekannt. Ich benutze ein Cakewalk UA-25EX ohne Probleme,
aber auch ohne Jack. Ich kann es nicht beschwoeren, aber ich denke
schon, dass ich offene ALSA-Verbindungen auch ueber mehrere Stunden hatte.

- Dirk

Ähnliche fragen