Falsche Bildschirmauflösung

13/06/2014 - 22:39 von Richard Fonfara | Report spam
Hallo,

eigentlich war ich ja mit den Grafiktreibern, die bei openSUSE 13.1 64
Bit von zu Hause aus dabei sind, recht zufrieden. Mich hat nur gestört,
dass beim Scrollen eine horizontale "Falte" mitgescrollt ist. Das habe
ich beseitigen wollen, indem ich von den Community-Repositories die von
nVidia installiert habe. Meine Grafikkarte ist eine GeForce GTX 560.

Meine Auflösung ist jetzt aber 1280 x 1024 statt 1600 x irgendwas.
Ursprünglich installiert waren:

libdrm_nouveau2
libdrm_nouveau2-32 bit
xf86-video-nv
xorg-x11-driver-video-nouveau

Dazugekommen sind:

nvidia-computeG03
nvidia-gfxG03-kmp-desktop
nvidia-glG03
nvidia-uvm-gfxG03-kmp-default
x11-video-nvidiaG03

Bei den meisten der Treiber, bei denen im Namen G03 vorkommt, steht in
der Beschreibung, dass sie für GeForce 8xxx seien, meine Karte hat aber
die Nr. 560.

Die "neuen" Treiber wieder deinstallieren oder gibt es eine Lösung?

Freundliche Grüße

Richard Fonfara
 

Lesen sie die antworten

#1 Martin Schnitkemper
14/06/2014 - 00:08 | Warnen spam
✉ Am Freitag, 13. Juni 2014 22:39 schrieb Richard Fonfara:

libdrm_nouveau2
libdrm_nouveau2-32 bit
xf86-video-nv
xorg-x11-driver-video-nouveau

Dazugekommen sind:

nvidia-computeG03
nvidia-gfxG03-kmp-desktop
nvidia-glG03
nvidia-uvm-gfxG03-kmp-default
x11-video-nvidiaG03



Die nouveau-Treiber vertragen sich nicht mit den nvidia-Treibern, deswegen
können sie nicht "dazukommen" sondern müssen durch diese ersetzt werden.

Wenn bei der Installation der nvidia-Treiber die nouveau-Kernelmodule nicht
blacklisted wurden (das Original-nvidia-Setup erkennt diesen Konflikt und
erledigt das) muss man das manuell nachholen, oder besser gleich die
nouveau-Pakete de-installieren.

Bei den meisten der Treiber, bei denen im Namen G03 vorkommt, steht in
der Beschreibung, dass sie für GeForce 8xxx seien, meine Karte hat aber
die Nr. 560.



Der aktuelle Treiber unterstützt alles ab GeForce 8:
http://www.nvidia.de/download/drive...x/75919/de

Die "neuen" Treiber wieder deinstallieren oder gibt es eine Lösung?



Erst einmal sicherstellen, dass wirklich nur noch die nvidia-Treiber werkeln
und nicht in Konflikt mit den nouveau-Treibern stehen.

Wenn das der Fall ist, mal /var/log/Xorg.0.log auf mögliche Fehler oder
Warnungen hin untersuchen.

Martin.
powered by Arch Linux x86_64 · Kernel: 3.14.4-1-ARCH · KDE: 4.13.1

Ähnliche fragen