Falsche Daten beim Verknüpfen von Access-Abfragen

22/01/2010 - 10:53 von Doctor Sid | Report spam
Folgendes Problem in Excel/Access 2007 (SP2) hat mich an den Rande des
Wahnsinns getrieben:
Wenn ich in Excel eine Access-Abfrage einbinde (Daten => Aus Access),
erhalte ich andere Daten als diese Abfrage in Access liefert.

Als Ursache konnte ich letztlich herausfinden, dass Access bei "LIKE"
Bedingungen (zB NICHT WIE "a*") den Stern (*) als Wildcard-Character
interpretiert, Excel aber das Prozentzeichen (%).

Aus meiner Sicht ein Bug so groß und schleimig, dass er locker bei Starship
Troopers mitspielen könnte.
 

Lesen sie die antworten

#1 anke.baumgarten01
10/01/2013 - 10:07 | Warnen spam
Am Freitag, 22. Januar 2010 10:53:01 UTC+1 schrieb Doctor Sid:
Folgendes Problem in Excel/Access 2007 (SP2) hat mich an den Rande des Wahnsinns getrieben: Wenn ich in Excel eine Access-Abfrage einbinde (Daten => Aus Access), erhalte ich andere Daten als diese Abfrage in Access liefert.Als Ursache konnte ich letztlich herausfinden, dass Access bei "LIKE" Bedingungen (zB NICHT WIE "a*") den Stern (*) als Wildcard-Character interpretiert, Excel aber das Prozentzeichen (%).Aus meiner Sicht ein Bug so groß und schleimig, dass er locker bei Starship Troopers mitspielen könnte.



...ich danke dir ganz fürchterlich - sitze auf Arbeit und habe seit Wochen dieses Problem. Haben erst auf Ofice 2007 umgestellt. Du bist meine Rettung - vielen Dank :-)
Wie hast du das rausgekriegt??

Gruß Anke

Ähnliche fragen