Forums Neueste Beiträge
 

Falsche Mittelwerte in Auswahlabfragen

02/08/2009 - 23:18 von Franz | Report spam
Die Auswahlabfrage gruppiert Datensàtze, die bereits in der Ausgangstabelle
mit einem Mittelwert erfasst waren.
Die Ausgangstabelle enthàlt aber auch noch leere Datensàtze, die noch nicht
erfasst sind, in denen aber bereits die Mittelwertfunktion hinterlegt ist.
Wenn man in der Auswahlabfrage die Mittelwerte nochmals als Mittelwerte (so
die Funktionsbox) angiebt, kommen falsche Mittelwerte heraus.
Liegt es an dem Problem der Mittelwerte der Mittelwerte oder an den "leeren"
Datensàtzen, die mitgerechnet werden?
Wie komme ich zu den richtigen Mittelwerten in der Auswahlabfrage?
 

Lesen sie die antworten

#1 Mark Doerbandt
02/08/2009 - 23:36 | Warnen spam
Hallo, Franz,

Franz:

Die Auswahlabfrage gruppiert Datensàtze, die bereits in der Ausgangstabelle
mit einem Mittelwert erfasst waren.
Die Ausgangstabelle enthàlt aber auch noch leere Datensàtze, die noch nicht
erfasst sind, in denen aber bereits die Mittelwertfunktion hinterlegt ist.
Wenn man in der Auswahlabfrage die Mittelwerte nochmals als Mittelwerte (so
die Funktionsbox) angiebt, kommen falsche Mittelwerte heraus.
Liegt es an dem Problem der Mittelwerte der Mittelwerte oder an den "leeren"
Datensàtzen, die mitgerechnet werden?
Wie komme ich zu den richtigen Mittelwerten in der Auswahlabfrage?



was passiert, wenn Du in der Abfrage die leeren Datensàtze auslàsst?

Warum werden die (berechenbaren) Mittelwerte abgespeichert?

Wie hinterlegst Du in einer Tabelle eine Funktion?

Gruss - Mark

Informationen fuer Neulinge in den Access-Newsgroups unter
http://www.doerbandt.de/Access/Newbie.htm

Bitte keine eMails auf Newsgroup-Beitràge senden.

Ähnliche fragen