favicon

09/03/2010 - 03:13 von Knut Singer | Report spam
Hi,

ich habe einen komischen Effekt mit FF 3.6:

Ich habe ein Favicon für eine Webseite konstruiert.
Eingebunden habe ich es nicht per HTML-Kommando im Header des
Quelltextes, sondern einfach nur durch Ablegen der Datei favicon.ico im
Rootverzeichnis der Webseite.

Die Webseite ist erreichbar unter www.meinedomain.de aber auch unter
meinedomain.de.

Wenn ich nun meinededomain.de aufrufe, zeigt mir FF das Favicon brav an.
Rufe ich www.meinedomain.de auf, dann fehlt das Favicon.

Keine Abhilfe brachten folgende Versuche, die ich durch Googlen fand:
- Cache leeren mit Strg-F5
- Anzeigen des Favicons per www.meinedomain.de/favicon. Hier wird das
Icon zwar im Bereich der Seite wie erwartet angezeigt, ebenso links
neben der Adresse, wie es sein soll. Wenn ich aber danach wieder
www.meinedomain.de aufrufe, fehlt das favicon trotzdem wieder.

Nun dachte ich, dass vielleicht der Webserver etwas mit der Auslieferung
des Icons zu tun hat und hier die Erklàrung zu suchen sei, weil
vielleicht der Provider etwas mit den Subdomains anders handhabt.

Im IE8 aber wird das Icon brav unter beiden Domains angezeigt, also
scheidet der Webserver wohl als Ursache aus.
Ebenso das Format des Icons, denn der FF zeigt es ja bei einer der
Domains an...

Was ist da wohl los?

Danke,
Knut



Niemand ist wirklich gesund,
er ist allenfalls noch nicht ausreichend untersucht.
 

Lesen sie die antworten

#1 Florian Diesch
09/03/2010 - 04:03 | Warnen spam
Knut Singer writes:

Ich habe ein Favicon für eine Webseite konstruiert.
Eingebunden habe ich es nicht per HTML-Kommando im Header des
Quelltextes, sondern einfach nur durch Ablegen der Datei favicon.ico im
Rootverzeichnis der Webseite.

Die Webseite ist erreichbar unter www.meinedomain.de aber auch unter
meinedomain.de.

Wenn ich nun meinededomain.de aufrufe, zeigt mir FF das Favicon brav an.
Rufe ich www.meinedomain.de auf, dann fehlt das Favicon.



Ich sehe weder bei http://www.meinedomain.de noch bei
http://meinedomain.de ('meinededomain.de' ist ein Tippfehler, nehme ich
an) ein Favicon. /favicon.ico existiert auf beiden Domains nicht.



Florian
<http://www.florian-diesch.de/>

Ähnliche fragen