FBSD7: Invalid Partition

12/11/2007 - 17:05 von Gerrit Kuehn | Report spam
Hallo Leute,

ich habe gerade mal meinen ersten Rechner auf 7-stable gezogen, was aber
leider ein bißchen schiefgegangen ist:
Nach dem Booten des neuen Kernel war noch alles ok, das installworld
lief ebenfalls fehlerfrei. Als ich dann aber das komplette neue System
booten wollte, fand der Bootloader auf einmal keine Partition mehr:
Nach der Auswahl kommt nur noch "invalid partition".

Ich bin bis jetzt nicht so richtig schlau geworden, was man am
loaderprompt eigentlich eingeben muß, damit etwas sinnvolles dabei
herauskommt. Wenn ich von CD boote, wird die Festplatte korrekt als ad4
gefunden, das System liegt eigentlich auf ad4s1a. Bisher hat der loader
einwandfrei funktioniert. Kann mir jemand einen Tipp geben, wie ich das
reparieren kann (und vielleicht auch erklàren, was da eigentlich
kaputtgegangen ist)?


cu
Gerrit
 

Lesen sie die antworten

#1 Gerrit Kuehn
12/11/2007 - 17:26 | Warnen spam
Gerrit Kuehn wrote:

lief ebenfalls fehlerfrei. Als ich dann aber das komplette neue System
booten wollte, fand der Bootloader auf einmal keine Partition mehr:
Nach der Auswahl kommt nur noch "invalid partition".



Kurze Ergànzung:
Aus irgendeinem Grund sind mir zwischendurch die Platten
durcheinandergegangen. Auf der richtigen findet der loader jetzt den
Kernel und alle Module, aber danach (direkt hinter "FreeBSD/i386...") kommt

Can't work out which disk we are booting from.
Guessed BIOS device 0xffffffff not found by probes, defaulting to disk0:

panic: free: guard1 fail @ 0x6c23c from
/usr/src/sys/boot/i386/loader/../../common/module.c:959

press any key to reboot


Hat hierzu jemand eine Idee? An den BIOS-Einstellungen habe ich beim
Update nichts geàndert.


cu
Gerrit

Ähnliche fragen