Fedora 8 / Aiptek Tablett

23/01/2009 - 18:20 von Ralph Stahl | Report spam
(f'up de.comp.os.unix.linux.hardware)

Moin,

ich habe ein àlteres Aiptek-Tablett T-6000U (USB) und möchte das gern
für Gimp etc nutzen. Ich habe weder Gnome noch KDE in Betrieb (aber
drauf), sondern IceWM. Das Problem: das Tablett ist da, funktioniert
auch an einer Windoof-Kiste, aber hier nicht.

So weit bin ich gekommen:

- das Kernelmodul ist da (lsmod zeigt "aiptek")

- eine 58-aiptek.rules für udev ist da, sie erzeugt beim Anstecken ein
/dev/input/aiptektablet

- xorg.conf:
Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
InputDevice "cursor" "SendCoreEvents"
InputDevice "stylus" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection
Section "InputDevice"
Identifier "stylus"
Driver "aiptek"
Option "Device" "/dev/input/aiptektablet"
Option "Type" "stylus"
Option "Cursor" "stylus"
Option "Mode" "absolute"
Option "TopX" "10"
Option "TopY" "10"
Option "BottomX" "24360"
Option "BottomY" "18240"
Option "MaxZ" "512"
Option "USB" "on"
EndSection
Section "InputDevice"
Identifier "cursor"
Option "Mode" "relative"
(... Rest wie stylus)
EndSection

Section "InputDevice"
Identifier "eraser"
Option "Mode" "absolute"
(... Rest wie stylus)
EndSection

- z.B. kinfocenter zeigt das Tablett als vorhanden, Gimp zeigt die
zusàtzlichen Zeichengeràte - aber sonst ist Funkstille. Also schon ein
cat /dev/input/aiptektablet zeigt nicht den erwarteten Zeichensalat.

Was kann/muß ich noch tun? Ratlos.

Ralph
 

Lesen sie die antworten

#1 Ralph Stahl
24/01/2009 - 13:59 | Warnen spam
Ergànzung:

Xorg.0.log zeigt (nachdem ich an jedes Device noch debuglevel 20
drangeschrieben habe):

xf86AiptekProc() type=cursor flags4 request=1
xf86AiptekProc request=ON
In xf86AiptekOpenDevice, with fd=-1
(==) HID Device name: "Aiptek"
(==) HID Driver Version: 1.0.0
(==) HID Driver knows it has 3 devices configured
(==) HID Driver is using 18 as the fd
From ioctl() xCapacity)99
From ioctl() yCapacity"49
Screen 0: screenRatio = 1.25, tabletRatio = 1.33
Screen 0: 'X' Gap of 187 computed
Able to open aiptek device
xf86AiptekProc Success request=1
xf86AiptekProc() type=stylus flags3 request=1
xf86AiptekProc request=ON
Able to open aiptek device
xf86AiptekProc Success request=1
xf86AiptekProc() type=eraser flags6 request=1
xf86AiptekProc request=ON
Able to open aiptek device
xf86AiptekProc Success request=1

Sieht doch alles gut aus!?
Ralph

Ähnliche fragen