Fehelrmeldung bei der Dateneingabe in einem DGV

21/05/2008 - 15:06 von Hans Wagner | Report spam
Hallo,
ich erhalte sporadisch Fehlermeldungen wenn ich Daten in ein DGV Eingebe.

Die Entwicklungsumgebung bringt mit den Fehler:
System.NullReferenceException wurde nicht behandelt.
Message="Der Objektverweis wurde nicht auf eine Objektinstanz
festgelegt."
Source="System.Windows.Forms"
..

Wie kann ich den Fehler lokalisieren?
Ich habe schon in allen Modulen einen Try ... Chatch Block integriert.
Der Fehler làuft aber nie auf einen Try Block.

Welche Routine kann ich hierzu einbauen??
Danke
Hans
 

Lesen sie die antworten

#1 Oliver Denter
21/05/2008 - 17:59 | Warnen spam
Hans Wagner schrieb:
Hallo,
ich erhalte sporadisch Fehlermeldungen wenn ich Daten in ein DGV Eingebe.

Die Entwicklungsumgebung bringt mit den Fehler:
System.NullReferenceException wurde nicht behandelt.
Message="Der Objektverweis wurde nicht auf eine Objektinstanz
festgelegt."
Source="System.Windows.Forms"
..

Wie kann ich den Fehler lokalisieren?
Ich habe schon in allen Modulen einen Try ... Chatch Block integriert.
Der Fehler làuft aber nie auf einen Try Block.

Welche Routine kann ich hierzu einbauen??
Danke
Hans


Wie gibst Du die Daten denn in das DGV ein?
Direkt also per "dgv.rows.add(new DataGridViewRow)" oder per DataTable?

Irgendwann ist das Objekt welches du dem DGV gibts eben nothing, such
einfach mal alle Stellen an denen Du was einfügst, egal wie, und dann
bauste sowas ein:

if isnothing(object) then
stop
end if

wenn Du es dann in der IDE startest, dann hàlst Du genau an der Stelle
an, wenn die Daten nothing sind.

OD

Ähnliche fragen