Fehler 2473

16/12/2015 - 19:07 von Michael | Report spam
Hallo zusammen,
ich habe ein sehr ràtselhaftes Problem und finde keine Lösung:
Access 2013
Im Frontend wird eine temporàre Tabelle mit do while -next gelesen, die Daten z.T. umgeformt und in eine Tabelle im Backend geschrieben.
Ich habe schon mit mit addnew .. update und mit execute INSERT probiert - kein Unterschied
Manchmal funktioniert alles problemlos, manchmal bricht das System mit Fehler 2473 ab, manchmal schon beim ersten Datensatz, manchmal auch nach mehr als 100 Datensàtzen. Es ist keine Logik zu erkennen.
Die Daten sind in Ordnung; sie sind bei allen Versuchen identisch.

Vielen Dank für Hinweise, wo das problem liegen könnte!

Gruß
Michael
 

Lesen sie die antworten

#1 Karl Donaubauer
16/12/2015 - 19:21 | Warnen spam
Hallo!

Michael ha scritto:
ich habe ein sehr ràtselhaftes Problem und finde keine Lösung:
Access 2013
Im Frontend wird eine temporàre Tabelle mit do while -next gelesen, die Daten z.T. umgeformt und in eine Tabelle im Backend geschrieben.
Ich habe schon mit mit addnew .. update und mit execute INSERT probiert - kein Unterschied
Manchmal funktioniert alles problemlos, manchmal bricht das System mit Fehler 2473 ab, manchmal schon beim ersten Datensatz, manchmal auch nach mehr als 100 Datensàtzen. Es ist keine Logik zu erkennen.
Die Daten sind in Ordnung; sie sind bei allen Versuchen identisch.



Muss nicht sein, aber der Fehler kommt gerne bei Korruptionen, oft in
Objektmodulen. Da sucht man sich dann krumm, weil der Textcode in
Ordnung ist.

Wo steht der Code?
Vielleicht in einem Formularmodul bzw. wird von dort aufgerufen?
Dann versuche es mal komplett in einem Standardmodul und wenn es dort
immer klappt, dann das Formular mit SaveAsText etc. reparieren (s.a.
http://www.donkarl.com?FAQ1.27) oder neu erstellen.

Decompile würde ich auch probieren: http://www.donkarl.com?FAQ1.23

Servus
Karl
*********
Access FAQ: http://www.donkarl.com

Ähnliche fragen