Fehler: Auf das Objekt 'CDO.Message' konnte nicht zugegriffen werden.

13/09/2007 - 21:11 von Andreas Waning | Report spam
Hallo Ngs

ich will in einem .Net1.1 Prog eine Mail versenden. Dazu habe ich mir bei
Googlemail eine Mail Account angelegt.
(Mit den gleichen Daten habe ich ein .Net2.0 Beipiel getestet, funkioniert)



Meine Methode sieht folgendermassen aus:
(Weis jemand was da falsch sein kann.?)

private void Test2()
{
string smtpServer = "smtp.googlemail.com";
string userName = "andreaswaning@googlemail.com";
string password = "mypasswort";
int cdoBasic = 1;
int cdoSendUsingPort = 2;
MailMessage msg = new MailMessage();
if (userName.Length > 0)
{
msg.Fields.Add("http://schemas.microsoft.com/cdo/co...ver",
smtpServer);
msg.Fields.Add("http://schemas.microsoft.com/cdo/co...ort",
587) ;
msg.Fields.Add("http://schemas.microsoft.com/cdo/co...ing",
cdoSendUsingPort) ;
msg.Fields.Add("http://schemas.microsoft.com/cdo/co...ate",
cdoBasic);
msg.Fields.Add("http://schemas.microsoft.com/cdo/co...ame",
userName);
msg.Fields.Add("http://schemas.microsoft.com/cdo/co...ord",
password); }
msg.To = "awaning@gmx.de";
msg.From = "andreaswaning@googlemail.com";
msg.Subject = "Softwareneuerung";
msg.Body = "Message";
SmtpMail.SmtpServer = smtpServer;
SmtpMail.Send(msg);


}
 

Lesen sie die antworten

#1 Herfried K. Wagner [MVP]
13/09/2007 - 22:38 | Warnen spam
"Andreas Waning" schrieb:
ich will in einem .Net1.1 Prog eine Mail versenden. Dazu habe ich mir bei
Googlemail eine Mail Account angelegt.



Siehe:

<URL:http://www.systemwebmail.net/faq/4.aspx>

M S Herfried K. Wagner
M V P <URL:http://dotnet.mvps.org/>
V B <URL:http://dotnet.mvps.org/dotnet/faqs/>

Ähnliche fragen