Fehler bei der Initialisierung des Repositorys

21/04/2010 - 12:36 von Olaf Meltzer | Report spam
Beim Aufruf des Yast2 Softwareinstallationsmoduls wird mir folgender
Fehler gemeldet, nachdem die Zwischenspeicher (Caches) für die
angemeldeten Repos angelegt wurden:

Fehler bei der Initialisierung des Repositorys.
'repo': [|] Failed to cache repo (4).
Folgende Fehler sind aufgetreten:
- 'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo/solv'
'/var/cache/zypp/raw/repo'
Unknown checksum type: 8: sha256

Ich habe daraufhin mal alles unterhalb /var/cach/zypp gelöscht. Beim
Aufruf der Softwareinstallation wurden die Repos neu eingelesen, aber im
Endeffekt bekomme ich wieder dieselbe Fehlermeldung.

Wie ist das zu bereinigen?

Gruß -- Olaf Meltzer

openSUSE 11.1 (i586) mit Kernel 2.6.27.45-0.1-pae
KDE: 4.4.2 (KDE 4.4.2) "release 241"
 

Lesen sie die antworten

#1 Uwe Grauer
21/04/2010 - 14:07 | Warnen spam
Olaf Meltzer wrote:
Beim Aufruf des Yast2 Softwareinstallationsmoduls wird mir folgender
Fehler gemeldet, nachdem die Zwischenspeicher (Caches) für die
angemeldeten Repos angelegt wurden:

Fehler bei der Initialisierung des Repositorys.
'repo': [|] Failed to cache repo (4).
Folgende Fehler sind aufgetreten:
- 'repo2solv.sh' '-o' '/var/cache/zypp/solv/repo/solv'
'/var/cache/zypp/raw/repo'
Unknown checksum type: 8: sha256

Ich habe daraufhin mal alles unterhalb /var/cach/zypp gelöscht. Beim
Aufruf der Softwareinstallation wurden die Repos neu eingelesen, aber im
Endeffekt bekomme ich wieder dieselbe Fehlermeldung.

Wie ist das zu bereinigen?

Gruß -- Olaf Meltzer




Das kannst du nicht bereinigen.
Die Repository-Metadaten sind falsch erstellt worden.
Das Problem ist wohl schon bekannt.
Also abwarten bis neue Metadaten in allen Mirrors angekommen sind.

Uwe

Ähnliche fragen