Fehler bei der Installation von SP1 für VS2008

11/02/2009 - 23:31 von Thomas Kehl | Report spam
Hallo zusammen.

Ich versuche SP1 für VS2008 zu installieren. Wenn zu Beginn "Visual C++ 2008
SP1 - x86-Laufzeit" installiert werden sollte, bricht das Ganze ab. Dann
erscheint der Assistent mit dem Hinweis: "Schwerwiegender Fehler bei der
Installation".

Kann mir jemand einen Tipp geben, was ich noch versuchen könnte?
Besten Dank!

Viele Grüsse, Thomas

Folgendes steht im Protokoll:

[2/11/2009, 23:27:31] Action: Performing actions on all Items...

[2/11/2009, 23:27:31] (IronSpigot::ExeInstallerBase::ExeInstallerBase)
Created new ExePerformer for Exe item
[2/11/2009, 23:27:31]
(IronSpigot::CartmanExeInstallerBase::CartmanExeInstallerBase) Created new
CartmanExePerformer for Exe item
[2/11/2009, 23:27:31] (IronSpigot::CartmanExeInstaller::CartmanExeInstaller)
In CartmanExeInstaller::CartmanExeInstaller
[2/11/2009, 23:27:31] (IronSpigot::CompositePerformerBaseT<class
IronSpigot::MsiInstaller,struct IronSpigot::MspInstaller,struct
IronSpigot::MultipleMspInstaller,class
IronSpigot::ExeSelectingPerformer<class IronSpigot::ExeInstaller,class
IronSpigot::CartmanExeInstaller> >::PerformAction) Created new ExePerformer
for Exe item
[2/11/2009, 23:27:31] Action: Performing Action on Exe at
C:\Users\TA2BB~1.KEH\AppData\Local\Temp\Microsoft Visual Studio 2008
SP1\VC_x86Runtime.exe...

[2/11/2009, 23:27:31]
(IronSpigot::CartmanExeInstallerBase::PreCreateProcess) In PreCreateProcess
[2/11/2009, 23:27:31]
(IronSpigot::CartmanExeInstallerBase::PreCreateProcess)
m_pSetupWatcher->Connect succeeded
[2/11/2009, 23:27:31] (IronSpigot::ExeInstallerBase::Launch) Launching
CreateProcess with command line = VC_x86Runtime.exe /q /progress
CartmanSetupExeWatcher1016343144
[2/11/2009, 23:27:31]
(IronSpigot::CartmanExeInstallerBase::PostCreateProcess) PostCreateProcess
succeeded
[2/11/2009, 23:27:53]
(IronSpigot::ExeInstallerBase::EnsureExitCodeIsAnMSIErrorCode) Original exit
code: C:\Users\TA2BB~1.KEH\AppData\Local\Temp\Microsoft Visual Studio 2008
SP1\VC_x86Runtime.exe returned non-MSI error code: 0xc0000417 - (null)
[2/11/2009, 23:27:53] (IronSpigot::ExeInstallerBase::PerformAction) Exe log
file(s) :
[2/11/2009, 23:27:53] (IronSpigot::ExeInstallerBase::PerformAction)
C:\Users\TA2BB~1.KEH\AppData\Local\Temp\dd_VC_x86RuntimeUI376E.txt
[2/11/2009, 23:27:53] (IronSpigot::ExeInstallerBase::PerformAction) Exe
(C:\Users\TA2BB~1.KEH\AppData\Local\Temp\Microsoft Visual Studio 2008
SP1\VC_x86Runtime.exe) failed with 0x80070643 - Schwerwiegender Fehler bei
der Installation. .
[2/11/2009, 23:27:53] (IronSpigot::ExeInstallerBase::PerformAction) Log
File: dd_VC_x86RuntimeUI376E.txt
[2/11/2009, 23:27:53] (IronSpigot::ExeInstallerBase::PerformAction)
PerformOperation on exe returned exit code 1603 (translates to HRESULT =
0x80070643)

[2/11/2009, 23:27:53] Action complete
[2/11/2009, 23:27:53] (IronSpigot::LogUtils::LogFinalResult) Final Result:
Installation failed with error code: (0x80070643), Schwerwiegender Fehler
bei der Installation.

[2/11/2009, 23:27:53] Action complete


Und folgendes in der erwàhnten Textdatei:

[02/11/09,23:27:36] = Logging started [02/11/09,23:27:36] [02/11/09,23:27:36] Pending Reboot Table state : Logging start
[02/11/09,23:27:36] _________________________________________
[02/11/09,23:27:36] (, )
C:\Users\TA2BB~1.KEH\AppData\Local\Temp\_iu14D2N.tmp ( - )
(--:--:--) Delete
[02/11/09,23:27:36] (, ) C:\Config.Msi\1cd692.rbf ( - ) (--:--:--)
Delete
[02/11/09,23:27:36] (, ) C:\Config.Msi\1cd6be.rbf ( - ) (--:--:--)
Delete
[02/11/09,23:27:36] (, ) C:\Config.Msi\1cd6c4.rbf ( - ) (--:--:--)
Delete
[02/11/09,23:27:36] (, ) C:\Config.Msi\1cd6f6.rbf ( - ) (--:--:--)
Delete
[02/11/09,23:27:36] (, ) C:\Config.Msi\1cd735.rbf ( - ) (--:--:--)
Delete
[02/11/09,23:27:36] (, ) e:\9fccdc20b52fe21c226a27423e2ffdf9 ( - )
( Wed Feb 11 19:20:56 2009 ) Delete
[02/11/09,23:27:36] (, ) e:\c23c843fdcdd6b481cd2a9 ( - ) ( Wed Feb
11 19:26:06 2009 ) Delete
[02/11/09,23:27:36] (, ) e:\c23c843fdcdd6b481cd2a9 ( - ) ( Wed Feb
11 19:26:06 2009 ) Delete
 

Lesen sie die antworten

#1 Thomas Griepentrog
12/02/2009 - 11:08 | Warnen spam
Hallo Thomas,

[viel Text aus Logfile]

also, ich hab mal die ErrorCodes bei google gesucht und folgendes gefunden:
[0x80070643]
http://forums.techarena.in/windows-...606604.htm
führt zu folgender seite:
http://support.microsoft.com/kb/923100

Der ErrorCode 1603 steht ja auch in deinem Log.

Hoffe, das hilft dir.

Thomas

Ähnliche fragen