Fehler bei der Validierung von ViewState-Mac

24/10/2009 - 10:43 von Alberto Luca | Report spam
Hallo NewsGroup,

einige Anwender bekommen sporadisch folgenden Fehler:

Fehler bei der Validierung von ViewState-MAC. Wenn diese Anwendung von einer
Webfarm oder einem Cluster gehostet wird, stellen Sie sicher, dass die
<machineKey>-Konfiguration den gleichen validationKey und
Validierungsalgorithmus angibt. AutoGenerate kann in einem Cluster nicht
verwendet werden.


Dieser Fehler verfolgt mich nun schon làngere Zeit.
Leider kann ich auf meinem Rechner den Fehler nicht provozieren.

Fakts:
- mein Provider setzt keine Webfarm oder Cluster ein
- es wird kein GridView und auch kein AJAX verwendet
- Verwendung von MasterPage und WebForms; einige Forms sind geschützt
(anmeldepflichtig; asp:LoginName, asp:LoginStatus, etc.)

Die Links von Thomas Bandt haben mir leider bisher auch nicht
weitergeholfen:
http://blog.thomasbandt.de/39/2234/...e-mac.html

(Zwischenzeitlich bin ich auch schon auf vs2008 umgestiegen.)
Wie könnte ich mich also dem Problem am besten nàhern (Logdateien, etc.)?

Besten Dank vorab!
Ciao, Alberto
 

Lesen sie die antworten

#1 Gerold Mittelstädt
24/10/2009 - 14:40 | Warnen spam
Hallo,

Alberto Luca schrieb:
einige Anwender bekommen sporadisch folgenden Fehler:

Fehler bei der Validierung von ViewState-MAC.



Das hatten wir doch erst vor 3 Tagen.. :)

http://groups.google.de/group/micro...3dd7dff199


Die Links von Thomas Bandt haben mir leider bisher auch nicht
weitergeholfen:
http://blog.thomasbandt.de/39/2234/...e-mac.html



Hm.. Faszinierend in welchen Szenarien der Fehler sonst noch auftritt.

machineKey setzen und jut is. :)

Viele Grüße!

Ähnliche fragen