Fehler bei kleinstem Programm

28/02/2008 - 23:17 von Tamara Mikes | Report spam
Salü alle zusammen

Ich habe eine ganz einfache kleine Anwendung geschrieben die lokal total gut
làuft. Aber auf dem Server bekomme ich immer folgende Fehlermeldung:


http://stellensuche.somee.com/test/default.aspx

Server Error in '/' Application.

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>




Der quelltext meiner Datei ist:

<%@ Page Language="vb" AutoEventWireup="false" CodeBehind="default.aspx.vb"
Inherits="stellenmarkt._default2" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xht...">

<html xmlns="http://www.w3.org/1999/xhtml" >
<head runat="server">
<title>Unbenannte Seite</title>
</head>
<body>
<form id="form1" runat="server">
<div>
Das ist einfach nur eine Testseite ohne nichts.</div>
</form>
</body>
</html>


Habe schon versucht auf on umzuschalten und eine eigene Fehlerseite zu
schreiben mit response.write(Server.GetLastError.InnerException.Message),
aber es kommt immer auf das Gleiche raus.

Kann mir jemand sagen was ich falsch mache? Was muss ich tun das mein
einfacher Test kommt?

Vielen Dank für jeden Hinweis
Gruss Tamara
 

Lesen sie die antworten

#1 Patrick Finger
28/02/2008 - 23:46 | Warnen spam
Hallo

Das heisst man kommt gar nicht bis zur Anzeige des Fehlers da dies in
der web.config ausgeschaltet ist.

- Entweder Du connectest Dich mit einem auf dem Server installierten
Browser zur Applikation
- Oder Du befolgst die Angweisung in der aktuellen Ausgabe und passt
Deine web.config wie angegeben an:
<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Dann sollte der eigentliche Fehler ausgegeben werden.

HTH, Gruss

Ähnliche fragen