Fehler beim Ausführen eines Paketes

11/12/2008 - 15:42 von Patrick Lange | Report spam
Hallo Zusammen,

ich habe da wieder eines der alt bekannten Probleme.

Es wurde ein SSIS Paket auf einem 32Bit Rechner entwickelt und soll nun auf
einem SQl Server 2005 64Bit Cluster laufen (Beides Enterprise Versionen).
Die Pakete sind auf der Dateiebenen der 32Bit Maschine abgelegt. Ich besitze
auf beiden Maschinen Admin Rechte. Das Paket soll ein Verzeichnis mit WMI
überwachen:

"SELECT *
FROM __InstanceCreationEvent WITHIN 10
WHERE
TargetInstance ISA "CIM_DirectoryContainsFile"
and
TargetInstance.GroupComponent="Win32_Directory.Name=\"c:\\\\KKSDIR_IN\""

Im Entwicklungsmodus làuft alles fehlerfrei durch. Erstelle ich aber ein
Paket, bekomme ich die Fehlermeldung:

Fehler: Der Task ... kann in dieser Edition von Integration Services nicht
ausgeführt werden. Es ist eine Edition einer höheren Stufe erforderlich.

Was kann ich da machen?
Welche Rechte müssen auf dem SQL-Server gesetzt werden.

Danke
Gruß Patrick Lange
 

Lesen sie die antworten

#1 Gerald Aichholzer
11/12/2008 - 16:41 | Warnen spam
Hallo Patrick,

Patrick Lange wrote:
ich habe da wieder eines der alt bekannten Probleme.

Es wurde ein SSIS Paket auf einem 32Bit Rechner entwickelt und soll nun auf
einem SQl Server 2005 64Bit Cluster laufen (Beides Enterprise Versionen).
Die Pakete sind auf der Dateiebenen der 32Bit Maschine abgelegt. Ich besitze
auf beiden Maschinen Admin Rechte. Das Paket soll ein Verzeichnis mit WMI
überwachen:

"SELECT *
FROM __InstanceCreationEvent WITHIN 10
WHERE
TargetInstance ISA "CIM_DirectoryContainsFile"
and
TargetInstance.GroupComponent="Win32_Directory.Name=\"c:\\\\KKSDIR_IN\""

Im Entwicklungsmodus làuft alles fehlerfrei durch. Erstelle ich aber ein
Paket, bekomme ich die Fehlermeldung:

Fehler: Der Task ... kann in dieser Edition von Integration Services nicht
ausgeführt werden. Es ist eine Edition einer höheren Stufe erforderlich.




ich verstehe die Fehlermeldung so, dass die Standard Edition von SSIS
ausgeführt wird, das Paket jedoch ein Feature verwendet, das nur in
der Enterprise Edition verfügbar ist.

lg,
Gerald

Ähnliche fragen