Fehler beim Zugriff auf die Systemregistrierung

04/11/2016 - 10:59 von Wilfried Dietrich | Report spam
Hallo,

meine VB6 Projekte / Entwicklungen laufen schon viele Monate in der IDE
(auch wenn ich diese nicht "Als Administrator ausführen" starte)
unter Windows 10 Fehler frei.
Der PC, an dem ich programmiere, ist schon seit vielen Wochen nicht am
Netzwerk (vollkommen Stand-Alone), also keine Updates etc..

Vor einigen Tagen (ca. einer Woche) habe ich Abends den PC herunter gefahren,
am nàchsten Morgen wieder gestartet und ein Projekt in der IDE
öffnen wollen. Es erschien(en) die besagte(n) Fehlermeldung(en):
"Fehler beim Zugriff auf die Systemregistrierung"

Ich habe daraufhin verschiedene Projekte geöffnet und festgestellt,
dass alle eine Fehlermeldung bringen, die nicht nur die Standardsteuerelemente laden.
Breche ich das ganze ab (Laden des Projekts fortsetzen? = Nein)
kommen die Fehlermeldungen, bei einem erneuten Versuch das Projekt zu laden, weiterhin.

Und jetzt kommt's:
Klicke ich auf OK, dann bei "Laden des Projekts fortsetzen?" auf Ja
und wiederhole das für jedes "besondere" Steuerelement auf den
einzelnen Formen, kann ich anschließend das Projekt schließen und
wieder ohne Fehlermeldung(en) öffnen.
Wichtig! Beim Schließen darf das Projekt nicht gespeichert werden.

Ich habe dann eine ...log Datei in der die Steuerelemente und ihre
ungültigen Eigenschaften aufgeführt sind, ala:
Zeile ...: Klasse ... des Steuerelements war keine geladene Steuerelementklasse.
...
Zeile ...: Der Eigenschaftsname ... ist ungültig.
...

Was vor einigen Tagen passierte, habe ich Heute wieder und
würde es nun gern für immer ausmerzen.

Was muss ich tun und wie muss ich dabei vorgehen?

Danke im voraus,
Wilfried
 

Lesen sie die antworten

#1 Wilfried Dietrich
04/11/2016 - 11:32 | Warnen spam
Nachtrag:

Ich habe eine Kopie meines größten Projekts, welches fast
alle meine verwendeten nicht Standardsteuerelemente enthàlt,
mit "als Administrator ausführen" gestartet.
Es wurde ohne Fehlermeldung geladen und ich konnte es ohne Speichern-Nachfrage schließen.
Danach konnte ich alle Projekte auch als "nur in der Gruppe der Administratoren"
ohne Fehlermeldung laden.
Die Kopie möchte allerdings beim Schließen das ich das Projekt speichere,
obwohl ich nichts geàndert habe. Einmal gespeichert kommt diese Nachfrage nicht mehr.


Wilfried

Ähnliche fragen