Fehlermeldung abfangen

24/07/2010 - 11:08 von Ralf Brinkmann | Report spam
Guten Morgen!

Wenn Zelle A1 die Zeichenfolge "in" oder "Frau" enthàlt, soll in B1
nichts stehen, sonst "r" (ist für die Anrede in einem Serienbrief).

A B
-
xxin
xx r
Frau

Wie fange ich jetzt die blöde Fehlermeldung *WERT! ab, wenn das jeweils
Andere drinsteht oder die Zelle leer ist?

=WENN(ODER(SUCHEN("in";A1);SUCHEN("Frau";A1));"";r)

Gruß, Ralf
Windows XP Home SP3
Opera 10.70-3452
The Bat! Pro 4.2.36.4
 

Lesen sie die antworten

#1 Jörg Eisenträger
24/07/2010 - 12:21 | Warnen spam
Wie fange ich jetzt die blöde Fehlermeldung *WERT! ab, wenn das jeweils
Andere drinsteht oder die Zelle leer ist?

=WENN(ODER(SUCHEN("in";A1);SUCHEN("Frau";A1));"";r)



Das geht mit der Funktion ISTFEHLER(...).
In Deinem Fall z. B. so:

=WENN(UND(ISTFEHLER(SUCHEN("in";A1));ISTFEHLER(SUCHEN("Frau";A1))
);"r";"")


Gruß
Jörg
LPs auf CD brennen - so geht's: http://www.joergei.de/
E-Mail-Adresse existiert, wird aber nicht gelesen.

Ähnliche fragen