Fehlermeldung bei Importieren einer Tabelle aus SQL-Server

03/06/2008 - 15:18 von Paul Schmidinger | Report spam
Hallo Gruppe!

Wir haben eine SQL-Server-2005-Datenbank. Über ODBC sind die Tabellen mit
einer Access-.mdb-Datei verknüpft. Die Wartung funktioniert so wunderbar.

Zu Auswertungszwecken sollen die Tabellen nun in eine neue .mdb-Datei
IMPORTIERT werden (anstatt verknüpft). Bei einer bestimmten Tabelle gibt es
da eine Fehlermeldung, mit der wir nichts anfangen können:

"Das Datenbankmodul kann 'Info.ZW_eawz_relevant' nicht finden. Stellen Sie
sicher, dass es sich um einen gültigen Parameter oder Alias-Namen handelt,
der keine ungültigen Zeichen oder falsche Zeichensetzung enthàlt und dessen
Name nicht zu lang ist."

Damit kann ich nun rein gar nichts anfangen: Es gibt làngere Feldnamen in
anderen Tabellen wo es funktioniert, und Sonderzeichen oder Umlaute kommen
auch nicht drin vor.

Die betroffene Tabelle hat rund 90 Spalten, die Spalte lt. Fehlermeldung ist
die vorletzte. Datentyp BIT, NOT NULL. Andere Spalten haben den selben
Datentyp, da gibt's keine Probleme.

Hat wer eine Idee? Ansonsten fàllt mir nur ein, per Trial-and-Error an einem
Tabellenduplikat so lange Änderungen vorzunehmen bis es funktioniert und
daraus versuchen einen Schluss zu ziehen...

LG,
Paul
 

Lesen sie die antworten

#1 Peter Doering
03/06/2008 - 21:19 | Warnen spam
Hallo,

Paul Schmidinger wrote:

Wir haben eine SQL-Server-2005-Datenbank. Über ODBC sind die Tabellen mit
einer Access-.mdb-Datei verknüpft. Die Wartung funktioniert so wunderbar.

Zu Auswertungszwecken sollen die Tabellen nun in eine neue .mdb-Datei
IMPORTIERT werden (anstatt verknüpft).



Wie importiert ihr denn? Von Access aus per Datei - Externe Daten -
Importieren, oder per SSIS vom SQL Server aus?

Bei einer bestimmten Tabelle gibt es
da eine Fehlermeldung, mit der wir nichts anfangen können:

"Das Datenbankmodul kann 'Info.ZW_eawz_relevant' nicht finden. Stellen Sie
sicher, dass es sich um einen gültigen Parameter oder Alias-Namen handelt,
der keine ungültigen Zeichen oder falsche Zeichensetzung enthàlt und dessen
Name nicht zu lang ist."



An welcher Stelle kommt die Meldung?
Sind 'Info.ZW_eawz_relevant' Tabellen- und Feldname oder ist der Punkt im
Feldnamen? Falls letzteres, waere das der Grund.

Gruss - Peter

Ich beantworte keine Fragen per Email.
Mitglied im http://www.dbdev.org
FAQ: http://www.donkarl.com

Ähnliche fragen