Fehlermeldung im Primärindex

10/12/2009 - 10:11 von Lupus Goebel | Report spam
Hallöschen,

Habe da eine Tabelle, die hat als Autowert die Spalte ID. In der Tabelle
werden viel Daten gelöscht und neue angelegt.
Nun passiert folgendes. Der Autowert macht nicht an der letzten Stelle
weiter, sondern irgendwo mitten drin.
ID müsste den Wert 2306 lauten, aber es erscheint der Wert 1240 (die
zuvor irgendwann gelöscht wurde) und erhalte nebenbei diese Fehlermeldung:

\\\
Die von Ihnen vorgenommenen Änderungen an der Tabelle konnten nicht
vorgenommen werde, da der Index, Primàrschlüssel oder die Beziehung
mehrfach vorkommende Werte enthalten würde. Ändern Sie die Daten in den
Feldern, die gleiche Daten enthalten, entfernen Sie den Index, oder
definieren Sie den Index neu, damit doppelte Eintràge möglich sind, und
versuchen Sie es erneut.
///

Aussehen tut das so: <http://lupusdw.de/help/indexfehler_01.jpg>

Was làuft hier schief?

Làuft unter Access 2003 und WIN XP


MfG - Lupus Goebel
Der Sumpf- Morasthobbybastler und Anfaenger mit
Wissensdurst (http://www.lupusdw.de http://foto.lupusdw.de)
Urlaub macht man in Irland: http://www.eaglesnest-bb.com/
 

Lesen sie die antworten

#1 Karl Donaubauer
10/12/2009 - 10:22 | Warnen spam
Lupus Goebel wrote:
Habe da eine Tabelle, die hat als Autowert die Spalte ID. In der
Tabelle werden viel Daten gelöscht und neue angelegt.
Nun passiert folgendes. Der Autowert macht nicht an der letzten
Stelle weiter, sondern irgendwo mitten drin.
ID müsste den Wert 2306 lauten, aber es erscheint der Wert 1240 (die
zuvor irgendwann gelöscht wurde) und erhalte nebenbei diese
Fehlermeldung:
\\\
Die von Ihnen vorgenommenen Änderungen an der Tabelle konnten nicht
vorgenommen werde, da der Index, Primàrschlüssel oder die Beziehung
mehrfach vorkommende Werte enthalten würde. Ändern Sie die Daten in
den Feldern, die gleiche Daten enthalten, entfernen Sie den Index,
oder definieren Sie den Index neu, damit doppelte Eintràge möglich
sind, und versuchen Sie es erneut.
///

Aussehen tut das so: <http://lupusdw.de/help/indexfehler_01.jpg>

Was làuft hier schief?

Làuft unter Access 2003 und WIN XP



Wir haben immer wieder mal Diskussionen zu diesem Problem,
dessen Ursachen etwas nebulös sind. s. z.B.
http://groups.google.com/group/micr...77d550731/
speziell
http://groups.google.com/group/micr...f98dfe11a5
in dem auch der einzige offizielle diesbez. Bug angeführt ist.
Es scheint aber mindestens einen zweiten zu geben.

Servus
Karl
********* Ich beantworte keine Access-Fragen per Email. *********
Access-FAQ: http://www.donkarl.com

Ähnliche fragen