Fehlermeldung WERT# für die Erzeugung von Terminen

19/06/2011 - 13:31 von Klaus-G. Broscheit | Report spam
Hallo zusammen in dieser NG

In einer Excel-Tabelle (2010) habe ich in der Zelle A1 ein Datum
eingetragen.
Nach rechts (B1 - F1) ergeben sich Termine (Daten) aus dem Datum in Zelle A1
In den Zellen B1 – F1 errechnet sich der Termin aus bestimmten Werten, die
den
anfànglichen Termin (Datum) immer weiter reduzieren.
Da der erste Termin nicht immer feststeht, aber die Formeln schon in den
Zellen
vorhanden sein sollen, habe ich eine WENN-Funktion eingebaut und abgefragt,
wenn die
Zelle A1 leer ist, soll die Zelle rechts davon auch leer bleiben. In Zelle
B1 klappt das, aber
in Zelle C1 wird der Fehler WERT# erzeugt. Was muss korrigiert werden?
Hier meine bisherigen Formeln:
A1= manuelle Eingabe
B1 =WENN(A1 - $K$6 < 0;" ";A1 - $K$6) hier entsteht keine Fehlermeldung
C1 =WENN(B1 - $K$7 < 0;" ";B1 - $K$7 ) hier entsteht die Fehlermeldung
WERT#
Und die nachfolgenden Zellen haben auch den Fehler WERT#
Die absoluten Zellangaben in den Formeln beinhalten die Werte zur
Reduzierung der Termine.
Vielen Dank für die Antwort.

Gruß
Klaus-G. Broscheit
 

Lesen sie die antworten

#1 Claus Busch
19/06/2011 - 13:46 | Warnen spam
Hallo Klaus,

Am Sun, 19 Jun 2011 13:31:05 +0200 schrieb Klaus-G. Broscheit:

A1= manuelle Eingabe
B1 =WENN(A1 - $K$6 < 0;" ";A1 - $K$6) hier entsteht keine Fehlermeldung
C1 =WENN(B1 - $K$7 < 0;" ";B1 - $K$7 ) hier entsteht die Fehlermeldung



den Fehler in B1 würde ich abfangen mit:
=WENN(A1="";"";A1 - $K$6)
Wenn in der Zelle ein Leerstring stehen soll, dann sind das zwei DIREKT
aufeinanderfolgende Anführungszeichen. So wie du es geschrieben hast,
bekommst du ein Leerzeichen in ie Zelle.
In C1 und den folgenden Zellen bekommst du diesen Fehler, wenn die Zelle
davor leer ist, da ein Leerstring minus ein Wert immer einen Fehler
zurückgibt.Und in deinem Fall hast du ein Leerzeichen in der Zelle
stehen und das wird als Text interpretiert und Text minus Zahl ist auch
Fehler.
Probiere es in C1 und den folgenden Zellen mit:
=WENN(ISTFEHLER(B1 - $K$7 );"";B1 - $K$7 )


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen