Fehlfunktion: ping -a [hostname] gibt fälschlicherweise APIPA IP des Microsoft Failover Cluster Virtual Adapter zurück!?

30/04/2010 - 12:41 von Marc Bauer | Report spam
Hallo

ich habe das ein technisches Problem mit Commfaults Backup Software... die
làsst sich auf einem HyperV Cluster nicht installieren, wenn man mit
Firewall installiert. Hintergrund scheint nach einigen Analysen sowohl mit
Commfault als auch selbst zu sein, dass hier etwas mit der Namensauflösung
nicht stimmt. Dabei handelt es sich aber um keine DNS Fehler im klassischen
Sinne - denn hier ist alles perfekt.

Das Problem wird ein kleines bischen auch unter
http://blogs.technet.com/askcore/ar...art-4.aspx
beschrieben, aber die NIC Reihenfolge ist auf den Systemen richtig und somit
der Artikel nicht zutreffend. Auch das verschieben des "Local Area
Connection* 9" ganz ans Ende hat nichts geholfen. Der Microsoft Failover
Cluster Virtual Adapter ist die "Local Area Connection* 9" und "Local Area
Connection" ist der "HyperV Virtual Adapter". Beide sind "hidden" und
eigentlich nicht in meiner Hand...

Nachfolgend die Reihenfolge der bindings:

"Internet Protocol Version 4 (TCP/IPv4)":
enabled: Public Virtual Switch
enabled: Cluster Communications
enabled: Live Migration
disabled: Public Team #1
enabled: Local Area Connection
enabled: Local Area Connection* 9
disabled: Public-1
disabled: Public-2
disabled: Public-3
disabled: Public-4
enabled: iSCSI-1
enabled: iSCSI-2
enabled: iSCSI-3
enabled: iSCSI-4


Alles ist richtig und auch ein nslookup auf IP oder Hostname - alles
richtig. Mach ich einen "ping -a myhypervclusternode" kommt die 169.x.x.x
zurück und nicht die IP Addresse des "Public Virtual Switch" (10.x.x.x.) !??
Auf Systemen ohne HyperV Cluster gibt es diese Probleme mit der Reihenfolge
nicht.

Ich bin ratlos... den einzigen Workaround, den wir gefunden haben - war ein
Eintrag in der "hosts" Datei - aber das kann NICHT die Lösung sein!

Gruss
Marc
 

Lesen sie die antworten

#1 Marc Bauer
03/05/2010 - 15:57 | Warnen spam
Hallo

Hat jemand hier ein HyperV Cluster und kann mal "ping -a myhostname"
ausführen und sagen, ob er auch die falsche Antwort (APIPA IP) bekommt?

Gruss
Marc

Ähnliche fragen