Feiertage in Kalender zentral verwalten/verteilen

20/02/2009 - 14:57 von Jürgen N. | Report spam
Hallo!

bin dabei die Feiertage mittels den Script von msxfaq.de (feiertage.vbs)
zentral zu verteilen. Das Problem das ich zur Zeit
habe ist dass die Mailboxen vom AD nicht richtig ausgelesen werden.
Als Exchange setzten wir Version 2007 SP1 + Windows 2003 x64 ein, die DCs
sind ebenfalls 2003er Server.

Folgendermaßen bin ich vorgegangen:
als erstes habe ich für den Administrator die Leserechte auf die Postfàcher
mit folgendem Befehl festgelegt:
"Add-ADPermission -Identity "DBName" -user "administrator" -ExtendedRights
Receive-As"

Zum Testen mit vorerst einer Mailbox habe ich im Script beim Eintrag
"mailboxnickname" meine e-Mail Adresse eingetragen anstatt "*"

Auf einem Windows 2003 Memberserver (als Administrator angemeldet) habe ich
dann CDO 1.2.1 (ExchangeMapiCdo.MSI)
installiert und das Script dann mit c:\"cscript feiertage.vbs" gestartet.

Das Script startet auch ganz normal, jedoch werden die Mailboxen vom AD
nicht richtig ausgelesen, im Logfile steht am
am Ende folgendes:

20.02.2009 13:00:20,Dbg5,Looking for GCstrGCPath=GC://domainxyz.com
20.02.2009 13:00:21,Out0,Total Mailboxes to check:0
20.02.2009 13:00:21,Dbg6, newlogentry: 3 - Loading List of Mailboxes from
AD DONE: Total:0
20.02.2009 13:00:21,Out0,Total Mailboxes checked:0
20.02.2009 13:00:21,Out0,# inspected:0
20.02.2009 13:00:21,Out0,# Total Importiert:0
20.02.2009 13:00:21,Out0,# Error:0

hat jemand einen Tip was der Grund dafür sein könnte bzw. wie das überprüfen
kann?


mfg,

Jürgen N.
 

Lesen sie die antworten

#1 Frank Carius \(MVP\)
22/02/2009 - 02:32 | Warnen spam
"Jürgen N." schrieb im Newsbeitrag
news:

bin dabei die Feiertage mittels den Script von msxfaq.de (feiertage.vbs)
zentral zu verteilen. Das Problem das ich zur Zeit
habe ist dass die Mailboxen vom AD nicht richtig ausgelesen werden.



Du hast alles "Mustergültig" gemacht,
Also mit erst mal eine Mailbox etc.

Das Script startet auch ganz normal, jedoch werden die Mailboxen vom AD
nicht richtig ausgelesen, im Logfile steht am
am Ende folgendes:

20.02.2009 13:00:21,Out0,Total Mailboxes to check:0



Aber ich vermute du hast in der Zeile mit "mailnickname=*" eben deinen
Alias eingetragen oder ?
Du kannst den LDAP-Filter einfach in die MMC für Benutzer und COmputer
genauso bei benutzerdefinierte Anfragen eintragen.

ich denke da ist einfahc ein Tippfehler oder dein Alias ist anders.



Frank Carius MS Exchange MVP
Exchange FAQ auf http://www.msxfaq.de
Wenn es die Zeit erlaubt, dann rufe ich auch an. Nummer/Mailadresse ?
:-) --

Ähnliche fragen