Fenster baut sich nicht ganz auf...

22/12/2007 - 11:58 von Andreas Mahub | Report spam
Mahlzeit,

habe mal nach langer Zeit wieder eine Frage. Für unsere Silvesterparty habe
ich
mehrere kleine Programme geschrieben. Unter anderem eines wo sich die Leute
aus einer Playlist Musik wünschen können und dieses dann über das Netzwerk an
den Hauptrechner (der die Musik- und Lichtanlage wiederum steuert) schickt und
automatisch eingereiht wird. Klappt auch alles wunderbar.

Jetzt sitze ich an den Feinheiten. Sollte das Hauptprogramm abstürzen würden
auch alle angeschlossenen Clients abstürzen, weil sie kein Daten mehr bekommen
würden (z.B. für die anzeige des Countdowns bis 0 Uhr). Dafür habe ich
natürlich
vorgesorgt und lasse dann ein Fenster (ohne Rahmen ohne alles) aufgehen wo
ein großes Label drin ist "Verbindung zum Server verloren" was automatisch
auch
wieder weggeht wenn das Hauptprogramm wieder làuft.

Mein Problem ist aber:
Das Hinweis-Fenster öffnet sich nicht richtig. Man sieht den dunkelgrauen
"Rahmen"
und in der Mitte (wo das Label auftauchen sollte) sieht man noch das
eigentliche
Programm und das Label kommt teilweise überhaupt nicht (im Debugmodus nach
ca. 5 Sekunden im Release überhaupt nicht).

Wie kann ich das am elegantesten lösen das diese Windowsform sauber aufge-
baut wird, obwohl die MDI stàndig versucht wieder eine Verbindung
herzustellen?

Gruß
Andy
VB.Net User
 

Lesen sie die antworten

#1 Peter Götz
22/12/2007 - 15:00 | Warnen spam
Hallo Anreas,

überlege mal, ob Du selbst irgendjemand bei einem
Programm helfen könntest, von dem Du weder
weisst, was es wirklich macht oder tun soll und
von dessen konkretem Programmcode Du bisher
keine einzige Zeile gesehen hast?

Gruß aus St.Georgen
Peter Götz
www.gssg.de (mit VB-Tipps u. Beispielprogrammen)

Ähnliche fragen