Fensterrahmen fehlen nach Upgrade auf Lucid Lynx

14/05/2010 - 02:51 von usenet-ungelesen | Report spam
Hallo,

ich brauche Hilfe bei folgender Sache: Wir haben das Acer Travelmate 660
(Intelgrafik) meiner Liebsten per Systemupgrade von Ubuntu 9.04 auf 10.4
(Lucid Lynx) gebracht.

Mit dem neuesten Kernel (2.6.31-22) gestartet, bleibt der Bildschirm
irgendwann schwarz. Das ist anscheinend ein àrgerliches bekanntes
Problem mit der Intelgrafik und dem abgeschalteten KMS, aber darum geht
es nicht.(1)

Mit dem vorletzten Kernel (31-21) startet der Rechner durch, allerdings
fehlen alle Fensterrànder (Fenstertitel mit Schließ- und anderen Knöpfen
etc.)

Die kann ich beheben, indem ich unter System > Einstellungen >
Erscheinungsbild > Visuelle Effekte von »Keine« auf »Normal« umstelle.
Es erscheint ein Statusbalken »Nach verfügbaren Treibern wird
gesucht...«, und nach einer Bestàtigung, dass ich die Einstellungen
beibehalten möchte, sind die Fensterrànder wieder da, inklusive Schatten
und Effekten. Wenn ich ablehne, sind die Fensterrànder allerdings auch
wieder da, nur eben ohne Schatten etc.

Nur: Nach Ab- und wieder Anmelden ist der Zustand wieder der alte.

Bei einem neu angelegten Benutzer ist von Anfang an alles in Ordnung:
Fensterrànder sind da, Effekte sind »normal«.

Ich habe auf ubuntuusers.de im Wiki und im Forum recherchiert, außerdem
auch in englischsprachigen Foren. Ich bin nur begrenzt schlauer (außer
dass ich viel über Fenstermanager gelernt habe).

Andere mit diesem Problem starten Compiz oder gleich Metacity neu und
legen dann ein Startobjekt an, dass das automatisiert. Das halte ich
aber für keine Ursachenbekàmpfung, sondern einen Workaround. Denn bei
dem neuen User geht es doch so!

Ich würde gerne herauskriegen, was bei dem alten User schieflàuft, es
muss ja irgendeine Voreinstellung oder kaputte Nutzerkonfiguration sein,
meine ich. Aber was?

Gelöscht habe ich versuchshalber die Ordner .compiz, .gconf, .gnome2 und
.gnome2_private, jeweils ohne dass der Fehler mit den fehlenden
Fensterrahmen behoben wird. Er tritt auch mit dem neuen Standardthema
von Lucid auf, auf das der Desktop dann (unter anderem) zurückgesetzt
wird.

Mit meinem begrenzten Wissen will ich nicht weiter herumstochern.

Wie nun weiter? Wie kann man herausfinden, wo es hakt, und wie kann man
es reparieren? Gibt es irgendwelche Logs, in denen ein Hinweis steht?

Ich habe zwar keine Angst vor einem Terminal, aber bei eventuell
hilfreichen Antworten beachtet bitte, dass ich kein erfahrener Linuxer
bin und mich mit den Innereien nicht besonders auskenne.

Schon mal vielen Dank fürs Lesen bis hierher, vielleicht weiß ja jemand
weiter. Fragen beantworte ich gerne so gut ich kann.

Rainer

(1) Das würde ich natürlich trotzem gerne beheben. Ich habe gelernt,
dass man beim Booten das KMS für die Sitzung aktivieren kann und es dann
permanent einschalten müsste.
<http://ikhaya.ubuntuusers.de/2010/0...bleme-mit-
i845-i855-grafikkarten-auf/> sagt im Prinzip bei »Update:
Richtigstellung«, wie es geht: es muss beim Booten eine Option
hinzugefügt werden, aber das bekomme ich nicht hin. Genaueres dazu bei
Interesse auf Anfrage.
 

Lesen sie die antworten

#1 usenet-ungelesen
18/05/2010 - 01:27 | Warnen spam
Rainer Pleyer wrote:

[Nach Upgrade auf Lucid Lynx keine Fensterrahmen]

Ich würde gerne herauskriegen, was bei dem alten User schieflàuft, es
muss ja irgendeine Voreinstellung oder kaputte Nutzerkonfiguration sein,
meine ich. Aber was?

Gelöscht habe ich versuchshalber die Ordner .compiz, .gconf, .gnome2 und
.gnome2_private, jeweils ohne dass der Fehler mit den fehlenden
Fensterrahmen behoben wird. Er tritt auch mit dem neuen Standardthema
von Lucid auf, auf das der Desktop dann (unter anderem) zurückgesetzt
wird.

Mit meinem begrenzten Wissen will ich nicht weiter herumstochern.



ich habe nun doch herumgestochert. Naja, ich war nur etwas mutiger mit
den Konfigurationsdateien.

Folgende Verzeichnisse habe ich (auf Verdacht) verschoben:

.compiz .dbus .gconfd .gnome2_private .nautilus
.config .gconf .gnome2 .kde

...und nach Neuanmelden ist die Fensterdekoration wieder da. Dauerhaft.

Mit Fleiß könnte ich herausfinden, welche Konfiguration genau den Fehler
verursacht hat, aber so sehr langweile ich mich noch nicht.

[Start mit kernel 2.6.31-22 endet mit schwarzem Bildschirm]

(1) Das würde ich natürlich trotzem gerne beheben. Ich habe gelernt,
dass man beim Booten das KMS für die Sitzung aktivieren kann und es dann
permanent einschalten müsste.



Auch das habe ich gefunden, vielleicht kanns jemand gebrauchen:
Installiert ist Grub1, die Einstellungen dafür finden sich in
/boot/grub/menu.lst

Dort beim entsprechenden Kernel-Abschnitt in der Zeile, die mit "kernel"
beginnt, die Option "i915.modeset=1" anhàngen.

Grüße,
Rainer

Ähnliche fragen