Fetchmail und Fetchnews laufen unter 11.0 aus dem Ruder !?

07/09/2008 - 22:16 von Paul-Wilhelm Hermsen | Report spam
Wenn ich meinen Rechner starte, kann ich via fetchmail Post und via
fetchnews Nachrichten abholen. Alles làuft einwandfrei.
Nach einer gewissen Zeit jedoch, wàhrend der ich nichts am Rechner
unternehme, laufen diese beiden Programme seit neuestem ins Leere.

Fetchmail hustet mir was mit der Meldung:

fetchmail: 6.3.8 fragt pop.gmx.net ab (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage gestartet
fetchmail: getaddrinfo("pop.gmx.net","pop3s")-Fehler: »Servname« wird
für »ai_soctype« nicht unterstützt
fetchmail: Geben Sie die --service-Option an (siehe auch FAQ-Punkt R12).
POP3-Verbindung zu pop.gmx.net fehlgeschlagen: Keine Berechtigung
fetchmail: 6.3.8 fragt ab pop.gmx.net (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage beendet
fetchmail: Abfragestatus=2 (SOCKET)
fetchmail: 6.3.8 fragt pop.gmx.net ab (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage gestartet
fetchmail: getaddrinfo("pop.gmx.net","pop3s")-Fehler: »Servname« wird
für »ai_soctype« nicht unterstützt
fetchmail: Geben Sie die --service-Option an (siehe auch FAQ-Punkt R12).
POP3-Verbindung zu pop.gmx.net fehlgeschlagen: Keine Berechtigung
fetchmail: 6.3.8 fragt ab pop.gmx.net (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage beendet
fetchmail: Abfragestatus=2 (SOCKET)
fetchmail: 6.3.8 fragt pop.gmx.net ab (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage gestartet
fetchmail: getaddrinfo("pop.gmx.net","pop3s")-Fehler: »Servname« wird
für »ai_soctype« nicht unterstützt
fetchmail: Geben Sie die --service-Option an (siehe auch FAQ-Punkt R12).
POP3-Verbindung zu pop.gmx.net fehlgeschlagen: Keine Berechtigung
fetchmail: 6.3.8 fragt ab pop.gmx.net (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage beendet
fetchmail: Abfragestatus=2 (SOCKET)
fetchmail: 6.3.8 fragt imap.arcor.de ab (Protokoll IMAP) um So 07 Sep 2008
22:12:48 CEST: Abfrage gestartet
fetchmail: getaddrinfo("imap.arcor.de","imaps")-Fehler: »Servname« wird
für »ai_soctype« nicht unterstützt
fetchmail: Geben Sie die --service-Option an (siehe auch FAQ-Punkt R12).
IMAP-Verbindung zu imap.arcor.de fehlgeschlagen: Keine Berechtigung
fetchmail: 6.3.8 fragt ab imap.arcor.de (Protokoll IMAP) um So 07 Sep 2008
22:12:48 CEST: Abfrage beendet
fetchmail: Abfragestatus=2 (SOCKET)
fetchmail: Datei fetchids wird gelöscht.
fetchmail: normale Beendigung, Status 2
fetchmail: Datei fetchids wird gelöscht.

Und fetchnews hustet mir was mit der Meldung:

leafnode 1.11.6: verbosity level is 3, debugmode is 0
try_lock(timeout=5), fqdn="zentrik.homelinux.net"
news.arcor.de: connecting to port nntp...
error: unable to find service name nntp/tcp
news.arcor.de: connection failed.
WARNING: some servers have not been queried!
wrote active file with 17247 lines
Started process to update overview data in the background.
Network activity has finished.

Nach einem Reboot fàngt der Mist wieder von vorne an.
Zunàchst ist alles roger, dann verabschieden sich beide Programme wieder in
der von mir geschilderten Weise.

Seit wann das Problem auftritt, kann ich nicht sagen.
Ich habe überhaupt keine Vorstellung davon, wo ich suchen soll.
 

Lesen sie die antworten

#1 Dominic Valerie Casare
08/09/2008 - 12:39 | Warnen spam
On Sun, 7 Sep 2008, Paul-Wilhelm Hermsen wrote:
Wenn ich meinen Rechner starte, kann ich via fetchmail Post und via
fetchnews Nachrichten abholen. Alles làuft einwandfrei.
Nach einer gewissen Zeit jedoch, wàhrend der ich nichts am Rechner
unternehme, laufen diese beiden Programme seit neuestem ins Leere.

Fetchmail hustet mir was mit der Meldung:

fetchmail: 6.3.8 fragt pop.gmx.net ab (Protokoll POP3) um So 07 Sep 2008
22:12:48 CEST: Abfrage gestartet
fetchmail: getaddrinfo("pop.gmx.net","pop3s")-Fehler: »Servname« wird
für »ai_soctype« nicht unterstützt ^



pop3 != pop3s

Frage: Hast du etwas an der /etc/services geaendert bzw stehen dort die
Zeilen drin:

pop3s 995/tcp # pop3 protocol over TLS/SSL (was spop3)
pop3s 995/udp # pop3 protocol over TLS/SSL (was spop3)

Ansonsten waere wohl auch /etc/nsswitch.conf noch ein Kandidat[0].
Leider hat der jenige die Details vergessen, zu erwaehnen... ;-]

Dominic

[0]
http://groups.google.com/group/de.c...99b9955549

Ähnliche fragen