Filtern in mehreren Spalten

08/05/2008 - 21:39 von Ralf Brinkmann | Report spam
Hallo!

Gegeben sind Excel 2003 und eine Datentabelle mit rund 10 Spalten und
3000 Datensàtzen (eine andere Datenbanksoftware steht mir nicht zur
Verfügung).

Nun wollte ich ohne VBA mit dem Autofilter in zwei verschiedenen Spalten
("Auftrag" und "Ergebnis") nach einem Begriff ("Jugend") suchen (enthàlt
"Jugend"), und zwar mit ODER, weil der Begriff manchmal nur links,
manchmal nur rechts, manchmal auch in beiden Spalten auftaucht.
Insgesamt sollen auf diese Weise 36 Datensàtze gefunden und angezeigt,
der Rest ausgeblendet werden. Geht das irgendwie? Wahrscheinlich stehe
ich nur auf der Leitung.

Ferner würde ich gerne ganz links eine weitere Spalte einfügen, in der
die gefundenen und angezeigten Datensàtze (und nur die) durchnummeriert
werden. Also von 1 bis 36. Geht das auch irgendwie? Ein einfaches
=SUMME(A1;1) zàhlt ja alle Datensàtze durch, auch die ausgeblendeten.

Und schließlich wàre es nett, wenn man die angezeigten
Ergebnisdatensàtze zur besseren Übersichtlichkeit auch noch mit
bedingter Formatierung abwechselnd einfàrben könnte
(Zebrastreifenmuster). Da könnte man ja vielleicht die Zàhlung in Spalte
A zu Hilfe nehmen.

Wàre toll, wenn das alles machbar wàre und Ihr mir mal wieder
Erleuchtung verschaffen könntet. Mein Dank wir Euch ewig nachschleichen.

Gruß, Ralf
 

Lesen sie die antworten

#1 Stefan Anderl
09/05/2008 - 09:03 | Warnen spam
"Ralf Brinkmann" wrote:

Hallo!

Gegeben sind Excel 2003 und eine Datentabelle mit rund 10 Spalten und
3000 Datensàtzen (eine andere Datenbanksoftware steht mir nicht zur
Verfügung).

Nun wollte ich ohne VBA mit dem Autofilter in zwei verschiedenen Spalten
("Auftrag" und "Ergebnis") nach einem Begriff ("Jugend") suchen (enthàlt
"Jugend"), und zwar mit ODER, weil der Begriff manchmal nur links,
manchmal nur rechts, manchmal auch in beiden Spalten auftaucht.
Insgesamt sollen auf diese Weise 36 Datensàtze gefunden und angezeigt,
der Rest ausgeblendet werden. Geht das irgendwie? Wahrscheinlich stehe
ich nur auf der Leitung.



Würde ich auf die Schnelle so machen:

Mit der Funktion =verketten(a2;b2) den Inhalt der beiden auszuwertenden
Spalten in eine neue Spalte schreiben, hier am Beispiel A2 und B2 gezeigt.
Dann auf diese Spalte den Auto-Filter mit "enthàlt" anwenden.



Ferner würde ich gerne ganz links eine weitere Spalte einfügen, in der
die gefundenen und angezeigten Datensàtze (und nur die) durchnummeriert
werden. Also von 1 bis 36. Geht das auch irgendwie? Ein einfaches
=SUMME(A1;1) zàhlt ja alle Datensàtze durch, auch die ausgeblendeten.



Das geht mit =zàhlenwenn(C2;"Jugend"). C2 steht hier für die neue,
kombinierte Zelle. Entsprechend oft kopieren.

Und schließlich wàre es nett, wenn man die angezeigten
Ergebnisdatensàtze zur besseren Übersichtlichkeit auch noch mit
bedingter Formatierung abwechselnd einfàrben könnte
(Zebrastreifenmuster). Da könnte man ja vielleicht die Zàhlung in Spalte
A zu Hilfe nehmen.


Man kann den Wert der neuen Spalte A auswerten und ein bedingtes Format
setzen, dann ist es aber noch nicht abwechselnd.

Stefan Anderl

Wàre toll, wenn das alles machbar wàre und Ihr mir mal wieder
Erleuchtung verschaffen könntet. Mein Dank wir Euch ewig nachschleichen.

Gruß, Ralf

Ähnliche fragen