Flash ActiveX Probleme

28/10/2007 - 13:08 von Gerold Mittelstädt | Report spam
Hallo!

Ich versuche gerade das Flash ActiveX Steuerelemt einzubidnen. Bei VS2003
hatte das noch problemlos funktioniert.
Wenn ich jetzt allerdings einen Verweis hinzufüge, erhalte ich die
Fehlermeldung

Der abhàngige COM-Verweis stdole, Version=7.0.3300.0, Culture=neutral,
PublicKeyToken=b03f5f7f11d50a3a konnte nicht aufgelöst werden.
Eine Wrapperassembly für die AxShockwaveFlashObjects-Typbibliothek konnte
nicht erstellt werden. Eine Ausnahme vom Typ
Microsoft.Build.Tasks.ComReferenceResolutionException wurde ausgelöst.
\AxShockwaveFlashObjects

Und beim Versuch es im Designer einzubinden

Das ActiveX-Steuerelement konnte nicht ordnungsgemàß registriert werden.
Stellen Sie sicher, dass es ordnungsgemàß registriert ist

Wenn ich allerdings ein altes 1.1-Projekt öffne und konvertiere,
funktioniert alles problemlos.

Kann es sein, dass der ActiveX-Importer vom VS2005 irgendwo Mist baut?
Gibt es Alternativen einen Wrapper zu erstellen?


Viele Grüße!
 

Lesen sie die antworten

#1 Gerold Mittelstädt
28/10/2007 - 15:26 | Warnen spam
Also habs Problem gelöst, indem ich einfach dei
AxInterop.ShockwaveFlashObjects.dll die der Converter 1.1->2.0 hinterlassen
hat eingebunden hab.


Gerold Mittelstàdt schrieb:
Hallo!

Ich versuche gerade das Flash ActiveX Steuerelemt einzubidnen. Bei
VS2003 hatte das noch problemlos funktioniert.
Wenn ich jetzt allerdings einen Verweis hinzufüge, erhalte ich die
Fehlermeldung

Der abhàngige COM-Verweis stdole, Version=7.0.3300.0, Culture=neutral,
PublicKeyToken°3f5f7f11d50a3a konnte nicht aufgelöst werden.
Eine Wrapperassembly für die AxShockwaveFlashObjects-Typbibliothek
konnte nicht erstellt werden. Eine Ausnahme vom Typ
Microsoft.Build.Tasks.ComReferenceResolutionException wurde ausgelöst.
\AxShockwaveFlashObjects

Und beim Versuch es im Designer einzubinden

Das ActiveX-Steuerelement konnte nicht ordnungsgemàß registriert
werden. Stellen Sie sicher, dass es ordnungsgemàß registriert ist

Wenn ich allerdings ein altes 1.1-Projekt öffne und konvertiere,
funktioniert alles problemlos.

Kann es sein, dass der ActiveX-Importer vom VS2005 irgendwo Mist baut?
Gibt es Alternativen einen Wrapper zu erstellen?


Viele Grüße!



Viele Grüße!

Richtiges Kopieren vom Visual Studio nach Outlook Express:
Code auswàhlen -> Strg+C -> Notepad -> Strg+V -> Strg+A -> Strg+X -> OE
-> Strg+V
http://itc.napier.ac.uk/e-petition/...titionIDG8

Ähnliche fragen