Font-Problem unter X

31/05/2008 - 07:11 von Andreas Wittmann | Report spam
Hallo NG!

Ich habe mir kürzlich den momentanen Source von XFree86 runtergeladen
(4.7.0), kompiliert und eingespielt.

Seitdem habe ich das Phànomen das beim ersten Start von X mittels startx
"kleinere" Schriftarten als normal angezeigt werden als wie vor dem
Upgrade. Das betrifft die meisten X-Programme (basierend auf
gtk/qt/pure-x) bei mir. Das Problem besteht auch mit unterschiedlichen
Windowmanagern und selbst ohne Windowmanager ist es reproduzierbar.

Sobald ich aber X beende und neustarte (Nur X, nicht den Rechner ;-))
funktioniert alles wie es soll. Die Schriftarten haben die ursprüngliche
richtige Größe. Ich kann X sooft neustarten wie ich möchte, das Problem
existiert erst dann wieder sobald ich den Rechner restarte.

Bin für jeden Tipp und Hinweis dankbar!

lg
Andy

P.S:
Mein System: LFS, Linux 2.6.25, libc-2.7, x86/32bit
 

Lesen sie die antworten

#1 Alexander Griesser
31/05/2008 - 08:53 | Warnen spam
Andreas Wittmann schrieb:
Ich habe mir kürzlich den momentanen Source von XFree86 runtergeladen
(4.7.0), kompiliert und eingespielt.



Meinst du 7.4.0?

Seitdem habe ich das Phànomen das beim ersten Start von X mittels startx
"kleinere" Schriftarten als normal angezeigt werden als wie vor dem
Upgrade.



Hast du schon mal nach dem zweiten Start deines X Servers die beiden
Logfiles /var/log/Xorg.0.log (zweiter Start) und /var/log/Xorg.0.log.old
(erster Start) verglichen?

Gibts da eine Differenz die vielleicht darauf hinweist, warum das so
ist?

ciao,
Alex

Ähnliche fragen