Formatüberprüfungen

28/11/2009 - 16:37 von jbo | Report spam
Hallo,

ich erstelle mit E2007 viele Pivots. Hier werden sehr oft Datumsfelder
gruppiert nach Jahr & Monat usw.
Das aber funktioniert nur wenn alls Felder der Spalte ein korrektes
Datum haben. Oftmals sind dort aber Werte mit falschen formatierungen
enthalten und es ist immer sehr mühsam genau diese zu finden.
Ich meine, in Excell 2003 war mal eine Option zur Formatüberprüfung
oder àhnliches vorhanden mit der man solche Probleme schnell und gut
entgegentreten kann. Nur kann ich soetwas oder àhnliches in E2007
nicht finden.
Habt ihr einen Tipp?
danke.
 

Lesen sie die antworten

#1 Eberhard Funke
29/11/2009 - 20:42 | Warnen spam
Am Sat, 28 Nov 2009 07:37:30 -0800 (PST) schrieb jbo:

Das aber funktioniert nur wenn alls Felder der Spalte ein korrektes
Datum haben. Oftmals sind dort aber Werte mit falschen formatierungen
enthalten und es ist immer sehr mühsam genau diese zu finden.



Hallo Jibo,

Du sprichst einmal von einen korrekten und dann von einem (nur) falsch
*formatierten" Datum. Was is nu?

Fall 1
Formatierungen durcheinander 01.01.2009, 01.01.09, 1.1.2009, 1. Jan.2009
Klick auf den Spaltenkopf und gib über Menü Format --> Zellen (ggf.
benutzerdefiniert) das gewünschte Format ein.

Fall 2
Einige Zellen sind teilweise als Text formatiert. Markiere die Spalte -->
Menü Daten --> Text in Spalten --> feste Breite --> weiter --> weiter -->
Datum wàhlen.

Fall 3
Du hast "echt" falsche Datumsangaben, z. B. A1: 59.11.09
Daten in Spalte A ab A1.
B1=WENN(ISTZAHL(A1);"";ISTZAHL(A1)) und nach unten kopieren
(kannst Du auch für bedingte Formatierung in Spalte A nehmen)

BTW: VBA isdate(A1) mit A1: 59.11.09 gibt WAHR, also Vorsicht :-(

Mit freundlichen Grüssen Eberhard
XP home XL 2000
Eberhard(punkt)W(punkt)Funke(at)t-online.de

Ähnliche fragen