Formel in einer Pivot-Tabelle

28/08/2008 - 10:45 von Lothar Krause | Report spam
Ich habe folgende Formel in einer Pivot-Tabelle:

=WENN(ISTFEHLER(A1/B1*1000);0;A1/B1*1000)

Anstelle von 0 (Null) möchte ich "" (für leer bzw blank) einsetzen.

Wenn die Formel dann wie folgt aussieht:

=WENN(ISTFEHLER(A1/B1*1000);"";A1/B1*1000) erhalte ich als 'Ergebnis'

#Wert!

Wie muss die Formel aussehen, wenn ich als 'Rückgabe' leer (bzw. blank)
erhalten möchte.

Ich verwende Excel 2003.
 

Lesen sie die antworten

#1 Thomas Ramel
28/08/2008 - 19:36 | Warnen spam
Grüezi Lothar

Lothar Krause schrieb am 28.08.2008

Ich habe folgende Formel in einer Pivot-Tabelle:

=WENN(ISTFEHLER(A1/B1*1000);0;A1/B1*1000)

Anstelle von 0 (Null) möchte ich "" (für leer bzw blank) einsetzen.

Wenn die Formel dann wie folgt aussieht:

=WENN(ISTFEHLER(A1/B1*1000);"";A1/B1*1000) erhalte ich als 'Ergebnis'

#Wert!



Ja, der leere String stört die Pivot-Tabelle dann bei der Berechnung.
Daher bin ich der Ansicht, dass nur reine Zahlenwerte zurückgegeben werden
dürfen/können.

Wie muss die Formel aussehen, wenn ich als 'Rückgabe' leer (bzw. blank)
erhalten möchte.



Ich vermute mal sehr stark, dass das nicht möglich ist - ein *echtes* Blank
ist im Übrigen auch ausserhalb der PT nicht erzielbar, da die betreffende
Zelle dann ja immer eine Formel enthàlt.


Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Win XP Pro SP-2 / xl2003 SP-3]
Microsoft Excel - Die ExpertenTipps

Ähnliche fragen