Formel für Anzahl verschiedener Wochentage in Datumsliste?

30/08/2008 - 07:18 von Thomas Gehrmann | Report spam
Hallo NG,
ich stehe vor der Aufgabe, aus einer langen Liste (ca. 4.000) von
Datumswerten die Anzahl der darin enthaltenen Wochentage zu ermitteln -
also: Anzahl der Montage, Anzahl der Dienstage ... Anzahl der Sonntage. Für
den Fall, dass jedes Datum nur 1 mal vorkommt, habe ich bereits Formeln
gefunden. Das Problem ist aber, dass es auch mehrfach vorkommende Daten
gibt, und die dürfen dann nur 1 mal gezàhlt werden. Hier ein Beispiel:

25.08.2008 = Mo
26.08.2008 = Di
27.08.2008 = Mi
27.08.2008 = Mi
29.08.2008 = Sa

Als Ergebnis sollte mir die Formel dann je Wochentag also liefern

Montage: 1
Dienstage: 1
Mitwwoche: 2
Donnerstage: 0
Freitage: 0
Samstage: 1
Sonntage: 0

Hat jemand eine Idee, wie ich das hinkriegen kann?

Vielen Dank
Thomas
 

Lesen sie die antworten

#1 Thomas Ramel
30/08/2008 - 08:35 | Warnen spam
Grüezi Thomas

Thomas Gehrmann schrieb am 30.08.2008

ich stehe vor der Aufgabe, aus einer langen Liste (ca. 4.000) von
Datumswerten die Anzahl der darin enthaltenen Wochentage zu ermitteln -
also: Anzahl der Montage, Anzahl der Dienstage ... Anzahl der Sonntage.

Hat jemand eine Idee, wie ich das hinkriegen kann?



Als Möglichkeit kannst Du den Wochentag ermitteln und dann z.B. über
SUMMENPRODUKT() die Daten zàhlen.

Liste die Wochentage z.b. in C2:C8 auf; deine Daten seien in Spalte A.

Füge dann die folgende Formel in D2 ein und kopiere sie anschliessend nach
unten bis D8:

=SUMMENPRODUKT((TEXT($A$1:$A$500;"TTTT")Â)*($A$1:$A$500<>""))



Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Win XP Pro SP-2 / xl2003 SP-3]
Microsoft Excel - Die ExpertenTipps

Ähnliche fragen