Formel gesucht

01/12/2008 - 15:46 von Michael Mueller | Report spam
Hallo.

Folgendes ist gegeben:

Tabellenblatt 'A' mit folgenden Inhalt.
(Immer beginnend mit A1)

AG Januar Februar Màrz April
AG1-1 500 510 520 510
AG1-2 250 250 240 220
AG1-3 110 100 100 95
AG1-4 70 80 85 80

Tabellenblatt 'B' mit folgenden Inhalt.
(beginnend mit A1)

AG Januar Februar Màrz April
AG2-1 240 340 380 415
AG2-2 400 450 490 555
AG2-3 120 110 100 110
AG2-4 60 65 65 65

Das Monatsfeld enthàlt jeweils den 1., nur formatiert um den Monat
darzustellen (Januar => 1.1.2008)

Sagen wir nun ich suche für den Monat Màrz die TOP3-Maximalwerte und dessen
AG (Arbeitsgang) über beide Tabellenblàtter.
Was ich dann im Zielblatt bràuchte wàre (wobei der Monat immer von Hand
geàndert wird):

Monat 1.3.2008
AG1-1 520
AG2-2 490
AG2-1 380

Oder für den Januar:

Monat 1.1.2008
AG1-1 500
AG2-2 400
AG1-2 250

Geht sowas über eine Formel, Makro ist nicht gewünscht (auch wenn es damit
leicht machbar wàre).

Danke für Eure Hilfe.

Michi
 

Lesen sie die antworten

#1 Claus Busch
02/12/2008 - 01:22 | Warnen spam
Hallo Michael,

Am Mon, 1 Dec 2008 15:46:50 +0100 schrieb Michael Mueller:

AG Januar Februar Màrz April
AG1-1 500 510 520 510
AG1-2 250 250 240 220
AG1-3 110 100 100 95
AG1-4 70 80 85 80

Tabellenblatt 'B' mit folgenden Inhalt.
(beginnend mit A1)

AG Januar Februar Màrz April
AG2-1 240 340 380 415
AG2-2 400 450 490 555
AG2-3 120 110 100 110
AG2-4 60 65 65 65

Das Monatsfeld enthàlt jeweils den 1., nur formatiert um den Monat
darzustellen (Januar => 1.1.2008)

Sagen wir nun ich suche für den Monat Màrz die TOP3-Maximalwerte und dessen
AG (Arbeitsgang) über beide Tabellenblàtter.
Was ich dann im Zielblatt bràuchte wàre (wobei der Monat immer von Hand
geàndert wird):

Monat 1.3.2008
AG1-1 520
AG2-2 490
AG2-1 380



ich bin davon ausgegangen, dass deine Tabellen absolut identisch
aufgebaut sind, dass also z.B. Màrz in jeder Tabelle in Spalte D steht
und habe einmal 2000 Zeilen angenommen.
Schreibe dir in Tabelle3 in C1:
=VERGLEICH($B$1;A!$1:$1;0)
Damit erhàltst du die Monatsspalte in den Blàttern A und B
In B2 dann für das Maximum:
=MAX(INDIREKT("A!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));INDIREKT("B!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1)))
In B3 für den zweitgrößten Wert:
=MAX(KGRÖSSTE(INDIREKT("A!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));ZÄHLENWENN(INDIREKT("A!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));">="&B2)+1);KGRÖSSTE(INDIREKT("B!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));ZÄHLENWENN(INDIREKT("B!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));">="&B2)+1))
und runterziehen bis B4
In A2:
=WENN(ISTNV(INDEX(A!$A$2:$A$2000;VERGLEICH(B2;INDIREKT("A!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));0)));INDEX(B!$A$2:$A$2000;VERGLEICH(B2;INDIREKT("B!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));0));INDEX(A!$A$2:$A$2000;VERGLEICH(B2;INDIREKT("A!"&ADRESSE(2;$C$1)&":"&ADRESSE(2000;$C$1));0)))
und runterziehen bis A4.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate
Office 2003 SP3 / 2007 Ultimate SP1

Ähnliche fragen