Forums Neueste Beiträge
 

Formel mit WENN Abfragen zu lang??

09/06/2008 - 07:04 von Günter Fabian | Report spam
Hallo Excel Gemeinde,
ich habe "eine" Formel die folgendes in einem Tabellenblatt abfragt:
Erster Teil (Richtiges Ergebnis), zweiter Teil (Unentschieden), dritter
Teil (Tendenz und die daraus folgende Punkte Verteilung).
Mein Problem ist, dass es Sieben WENN Abfragen sind. Ich aber für die
Übersichtlichkeit eigentlich noch eine oder auch zwei WENN Abfragen noch
brauchte.
Hier die Formel als ganzes

=WENN(UND($BI$2=BI3;$BJ$2=BJ3);10;WENN(UND($BI$2-$BJ$2=0;BI3-BJ3=0);8
;WENN(ODER(UND(BI3<BJ3;$BI$2<$BJ$2);UND(BI3>BJ3;$BI$2>$BJ$2))
;WENN(CS3=0;10;WENN(CS3=1;6;WENN(CS3=2;4;WENN(CS3=3;3;WENN(CS3>=4;1;0))))))))

Die Formel gehört natürlich in einer Zeile :-)
Gibt es eventuell für den letzten Teil (die fünf wennŽs) eine kürzere
Variante?

Mit freundlichem Gruß

Günter
 

Lesen sie die antworten

#1 Wolfgang Habernoll
09/06/2008 - 08:09 | Warnen spam
Hallo Günter

"Günter Fabian" schrieb im Newsbeitrag
news:g2idl0$e4u$03$
Hallo Excel Gemeinde,
ich habe "eine" Formel die folgendes in einem Tabellenblatt abfragt:
Erster Teil (Richtiges Ergebnis), zweiter Teil (Unentschieden), dritter Teil
(Tendenz und die daraus folgende Punkte Verteilung).
Mein Problem ist, dass es Sieben WENN Abfragen sind. Ich aber für die
Übersichtlichkeit eigentlich noch eine oder auch zwei WENN Abfragen noch
brauchte.
Hier die Formel als ganzes

=WENN(UND($BI$2=BI3;$BJ$2=BJ3);10;WENN(UND($BI$2-$BJ$2=0;BI3-BJ3=0);8
;WENN(ODER(UND(BI3<BJ3;$BI$2<$BJ$2);UND(BI3>BJ3;$BI$2>$BJ$2))
;WENN(CS3=0;10;WENN(CS3=1;6;WENN(CS3=2;4;WENN(CS3=3;3;WENN(CS3>=4;1;0))))))))

Die Formel gehört natürlich in einer Zeile :-)
Gibt es eventuell für den letzten Teil (die fünf wennŽs) eine kürzere
Variante?



so könntest du dir 3 der letzten 5-WENN sparen

=WENN(CS3<0;0;WENN(CS3>=4;1;WAHL(CS3+1;10;6;4;3)))

mfG
Wolfgang Habernoll

[ Win XP Home SP-2 , XL2002 ]

Ähnliche fragen