Formel mittels VBA kopieren

31/05/2009 - 22:51 von Thom | Report spam
Hallo liebe NG

Ich muss in die Zelle B2 folgende Formel einfügen und dies mittels VBA.

=+WENN(P2<>"";P2;O2)

Danach eine weitere Formel in die Zelle h2

=+WENN(B2=P2;O2;WENN(P2="";"";P2))

Hat mir jemand einen Tipp?

Im voraus besten Dank.

Gruss Thom
 

Lesen sie die antworten

#1 Claus Busch
31/05/2009 - 23:26 | Warnen spam
Hallo Thom,

Am Sun, 31 May 2009 22:51:50 +0200 schrieb Thom:

Ich muss in die Zelle B2 folgende Formel einfügen und dies mittels VBA.

=+WENN(P2<>"";P2;O2)

Danach eine weitere Formel in die Zelle h2

=+WENN(B2=P2;O2;WENN(P2="";"";P2))



was sollen die +-Zeichen vor dem Wenn? Probiere es mal so:

Sub Formel()

With ActiveSheet
.Range("B2").FormulaLocal = "=WENN(P2<>"""";P2;O2)"
.Range("H2").FormulaLocal = "=WENN(B2=P2;O2;WENN(P2="""";"""";P2))"
End With

End Sub


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP1
Office 2003 SP3 / 2007 Ultimate SP1

Ähnliche fragen