Formel soll "leere" Zelle produzieren

14/07/2008 - 09:27 von Harald Battran | Report spam
Hallo,

ich brauch mal Hilfe bei einem Formatierungsproblem:

Ich habe eine "Kalenderleiste" (Kalendertage laufen horizontal in
einer Zeile z.B. 2:2) und darüber 1:1 möchte ich den

jeweiligen Monat anzeigen. Aber natürlich nur einmal am Monatsanfang
und nicht über jedem einzelnen Tag.

Also könnte in A1 stehen: =wenn(tag(A2)=1;text(A2;"MMMM"))

Nur schreibt Excel FALSCH in die Zelle wenn der darunterstehende Tag
eben nicht der Monatserste ist.

Natürlich kann ich die Formel anpassen und schreiben
=wenn(tag(A2)=1;text(A2;"MMMM");"") damit ein Leerer String gesetzt
wird. Aber ein Problem bleibt:

Lange Monatsnamen werden dann nicht vollstàndig ausgeschrieben, da ja
die rechts daneben stehenden Zellen einen - wenn auch leeren - String
beinhalten.

Gibt es eine Möglichkeit diese "Formatierungsproblem" zu umgehen?
Wichtig wàren mir Vorschlàge ohne die Zuhilfenahme von VBA.

Noch eine Frage: Kann man Zellenverbinden mit einer Formel machen?

Danke für jeden Hinweis.

Harald Battran
 

Lesen sie die antworten

#1 Claus Busch
14/07/2008 - 10:36 | Warnen spam
Hallo Harald,

probiers mal so:
=WENN(TAG(A2)=1;TEXT(A2;"MMMM");"")


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen