Formelberechnung abhängig von Zellwert (inhalt)

19/06/2008 - 13:36 von Marco | Report spam
Hallo zusammen

Ich habe ein kleines Problem: Ist es mit Excel möglich (ohne
Verwendung von Makros) abhàngig vom Inhalt einer Zelle eine Berechnung
in einer anderen Zelle auszuführen? Also konkret: in Zelle A1 fordere
ich den User auf die Spalte zu wàhlen, auf die sich die Berechnung
beziehen soll. Gibt er in A1 z.B. C an, soll der Mittelwert der in der
Spalte C befindlichen Daten ausgerechnet werden und z.B. in A2
ausgegeben werden. Làsst sich das ohne Makro überhaupt lösen? Klar,
ich könnte einfach eine Formel Mittelwert(C1:C100) in A1 schreiben und
jeweils den Bezug von Hand abàndern, aber das muss doch irgendwie
eleganter (und für den User weniger umstàndlich) gehen, oder? Besten
Dank für Eure Hilfe und liebe Grüsse aus der Schweiz

Marco
 

Lesen sie die antworten

#1 Claus Busch
19/06/2008 - 13:48 | Warnen spam
Hallo Marco,

Am Thu, 19 Jun 2008 04:36:06 -0700 (PDT) schrieb Marco:

Ich habe ein kleines Problem: Ist es mit Excel möglich (ohne
Verwendung von Makros) abhàngig vom Inhalt einer Zelle eine Berechnung
in einer anderen Zelle auszuführen? Also konkret: in Zelle A1 fordere
ich den User auf die Spalte zu wàhlen, auf die sich die Berechnung
beziehen soll. Gibt er in A1 z.B. C an, soll der Mittelwert der in der
Spalte C befindlichen Daten ausgerechnet werden und z.B. in A2
ausgegeben werden. Làsst sich das ohne Makro überhaupt lösen? Klar,
ich könnte einfach eine Formel Mittelwert(C1:C100) in A1 schreiben und
jeweils den Bezug von Hand abàndern, aber das muss doch irgendwie
eleganter (und für den User weniger umstàndlich) gehen, oder? Besten
Dank für Eure Hilfe und liebe Grüsse aus der Schweiz



deine Spalte steht in A1. Dann in A2 mal so probieren:
=MITTELWERT(INDIREKT(A1&"1"&":"&A1&"100"))


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate
Office 2003 SP2 / 2007 Ultimate

Ähnliche fragen