Frage bzg. 100MB-Systempartition

28/08/2011 - 14:21 von Günther Hohenstein | Report spam
Hallo,
ich habe auf meinem Rechner Win7 und Opensuse, Grub im MBR. Folge: SP1
làsst sich nicht installieren.
Der Fehler ist bekannt, die Lösung auch. Dazu muss die
100MB-Systempartition auf aktiv gesetzt und ihr anschließend
(vorübergehend) ein Laufwerksbuchstaben zugeordnet werden. Das klappt
bei mir leider nicht. In der entsprechenden Anzeige der Partitionen sehe
ich die 100MB-Partition zwar, aber ein Rechtsklick bietet mir nur Hilfe
an, die mir aber nicht weiterhilft.
Hat hier jemand einen Tipp, wie ich vorgehen sollte?

Mit bestem Gruß
Günther H.
 

Lesen sie die antworten

#1 Stefan Kanthak
28/08/2011 - 17:21 | Warnen spam
"Günther Hohenstein" schrieb:

Hallo,
ich habe auf meinem Rechner Win7 und Opensuse, Grub im MBR.



Wer hat denn diesen Bloedsinn verbrochen?

In den MBR gehoert KEIN BootManager, sondern irgendein strunzdummes
Stueckchen (MS-kompatibler) Code, das den Bootsektor der aktiven
Primaerpartition laedt. Der wiederum laedt den BootManager/Lader
dieser Partition.

Folge: SP1 làsst sich nicht installieren.



Falsch!
Das liegt NICHT am GRUB im MBR, sondern an der inaktiven Windows-
Systempartition!
GRUB ist es vollkommen wurscht, ob und welche Partition "aktiv"
gesetzt ist, der Installateur hat hier gleich zwei dumme Fehler gemacht!

Der Fehler ist bekannt, die Lösung auch. Dazu muss die
100MB-Systempartition auf aktiv gesetzt



Das Linux-fdisk kann das!

Du kannst auch im laufenden Windows die Windows-BootPartition aktiv
setzen, die 100MB-Partition loeschen und mit BOOTREC.EXE den Windows-
BootManager inkl. dessen BCD neu erzeugen.

und ihr anschließend (vorübergehend) ein Laufwerksbuchstaben zugeordnet
werden.



Ueberfluessig!

[...]

Stefan
[
Die unaufgeforderte Zusendung werbender E-Mails verstoesst gegen §823
Abs. 1 sowie §1004 Abs. 1 BGB und begruendet Anspruch auf Unterlassung.
Beschluss des OLG Bamberg vom 12.05.2005 (AZ: 1 U 143/04)

Ähnliche fragen