Frage Progressbar

30/07/2009 - 17:35 von Peter Schirmer | Report spam
Hallo,

ich habe ein Formular, auf der eine Progressbar ihren Dienst tut und
einfach von links nach rechts, um die Dauer eines Vorgangs zu visualisieren.

Wenn ich auf einen Button klicke funktioniert alles wunderbar; die Form
wird angezeigt und ich sehe die Progressbar.

Möchte ich aber an der Stelle, an der Prozess startet, deren Dauer ich
mit der Progressbar visualisieren möchte, die Progressbar anzeigen,
klappt es nicht richtig. Die Form ist zwar sichtbar, aber die
Progressbar fehlt; sie sieht eingefroren aus.

Was muss ich machen, um die Progressbar korrekt anzuzeigen, wàhrend mein
Prozess (innerhalb einer Methode) làuft?

Danke und Gruß
Peter
 

Lesen sie die antworten

#1 Peter Fleischer
30/07/2009 - 19:27 | Warnen spam
"Peter Schirmer" schrieb im Newsbeitrag
news:%

ich habe ein Formular, auf der eine Progressbar ihren Dienst tut und
einfach von links nach rechts, um die Dauer eines Vorgangs zu
visualisieren.

Wenn ich auf einen Button klicke funktioniert alles wunderbar; die Form
wird angezeigt und ich sehe die Progressbar.

Möchte ich aber an der Stelle, an der Prozess startet, deren Dauer ich mit
der Progressbar visualisieren möchte, die Progressbar anzeigen, klappt es
nicht richtig. Die Form ist zwar sichtbar, aber die Progressbar fehlt; sie
sieht eingefroren aus.

Was muss ich machen, um die Progressbar korrekt anzuzeigen, wàhrend mein
Prozess (innerhalb einer Methode) làuft?



Hi Peter,
ich vermute mal, dass dein Prozess vollstàndig die CPU belegt und keine
(Warte-) Zeit vorhanden ist, um automatisch die Oberflàche zu aktualisieren.
In diesem Fall kann ein DoEvents helfen.

Viele Grüsse
Peter

Ähnliche fragen