Frage zu Flachbandkabelentstörung

13/06/2015 - 10:55 von Stefan | Report spam
Hallo,


Ich hab vor einigen Jahren eine Mikroprozessorbaugruppe auf Basis
STM32F103 entworfen die mit einem TFT Touchscreen-Display ausgestattet
ist. Die zugekaufte Displayeinheit hat einen zweireihigen 40-poligen
(2x20) Anschluss im Raster 2,54mm. Der TFT-Controller befindet sich auf
dem Display. Angesteuert wird das über 16 Datenleitungen sowie RD, WR
und CS.

Das Display wird normalerweise direkt auf die Leiterplatte des
Mikroprozessorsystems gesteckt und so funktioniert das auch einwandfrei.

Jetzt hat mein Kunde gegen meinen ausdrücklichen Rat entschieden, das
Display von der Mikroprozessorplatine abzusetzen. Erst ging es um 30cm,
dann um 1m, zuletzt sollten es 1,5m sein.

Es funktionierte so einigermaßen nachdem wir die Geschwindigkeit der
STM32 GPIOs runter gesetzt haben, aber nicht perfekt, d.h. bei
ungünstiger Kabelverlegung gibt es Fehler auf dem Bild.

Meine Lösung wàre, den Mikroprozessor direkt am Display zu belassen und
eine weitere Platine zu installieren die dann abgesetzt wird. Das würde
auch gehen, wàre aber etwas teurer. Geht um ca. 50,- €, aber mein Kunde
will das nicht.

Ich hab jetzt Ferrite (Würth) für Flachbandkabel besorgt und meinem
Kunden ein Kabel mit zwei von diesen Ferriten geschickt. Damit kann er
erstmal rumprobieren. Hier bei mir kann ich das leider momentan nicht
testen und ich bin skeptisch, ob das überhaupt was bringt. Andere
Lösungen wie terminieren scheiden aus weil die Abschlusswiderstànde viel
zu niederohmig sein müssten und bei ca. 20 Terminatoren der Gesamtstrom
zu hoch würde.

Deshalb meine Frage: Machen die Ferrite Sinn, oder welche Optionen hab
ich noch?

Gruß

Stefan
 

Lesen sie die antworten

#1 Reinhardt Behm
13/06/2015 - 04:10 | Warnen spam
On 13.06.2015 16:55, Stefan wrote:
Hallo,


Ich hab vor einigen Jahren eine Mikroprozessorbaugruppe auf Basis
STM32F103 entworfen die mit einem TFT Touchscreen-Display ausgestattet
ist. Die zugekaufte Displayeinheit hat einen zweireihigen 40-poligen
(2x20) Anschluss im Raster 2,54mm. Der TFT-Controller befindet sich auf
dem Display. Angesteuert wird das über 16 Datenleitungen sowie RD, WR
und CS.

Das Display wird normalerweise direkt auf die Leiterplatte des
Mikroprozessorsystems gesteckt und so funktioniert das auch einwandfrei.

Jetzt hat mein Kunde gegen meinen ausdrücklichen Rat entschieden, das
Display von der Mikroprozessorplatine abzusetzen. Erst ging es um 30cm,
dann um 1m, zuletzt sollten es 1,5m sein.

Es funktionierte so einigermaßen nachdem wir die Geschwindigkeit der
STM32 GPIOs runter gesetzt haben, aber nicht perfekt, d.h. bei
ungünstiger Kabelverlegung gibt es Fehler auf dem Bild.

Meine Lösung wàre, den Mikroprozessor direkt am Display zu belassen und
eine weitere Platine zu installieren die dann abgesetzt wird. Das würde
auch gehen, wàre aber etwas teurer. Geht um ca. 50,- €, aber mein Kunde
will das nicht.



Das wàre das gescheiteste.

Ich hab jetzt Ferrite (Würth) für Flachbandkabel besorgt und meinem
Kunden ein Kabel mit zwei von diesen Ferriten geschickt. Damit kann er
erstmal rumprobieren. Hier bei mir kann ich das leider momentan nicht
testen und ich bin skeptisch, ob das überhaupt was bringt. Andere
Lösungen wie terminieren scheiden aus weil die Abschlusswiderstànde viel
zu niederohmig sein müssten und bei ca. 20 Terminatoren der Gesamtstrom
zu hoch würde.

Deshalb meine Frage: Machen die Ferrite Sinn, oder welche Optionen hab
ich noch?



Kunden wechseln ;-)
Aber im Ernst, die Ferrite helfen eigentlich nur gegen Abstrahlung,
indem sie die höherfrequenten Anteile in den Flanken dàmpfen. Sie helfen
auch gegen das Einfangen von Fremdstörungen. Aber das ist zur Zeit
(noch) nicht Deine Problem - kann aber noch kommen, wenn's denn erstmal
zuverlàssig làuft ohne Fremdstörung.

Mir fallen zwei Sachen ein:
- ordentlich Treiber auf der Prozessorseite und am Display Empfànger mit
Schmitt-Trigger. Die Strecke vielleicht mit irgendwas differentiellem
fahren. Das wird aber fast ein neues Layout für beide Seiten.
- Am Display die Stromversorgung mit Cs besser abblocken. Ich habe schon
oft erlebt, dass das die Masse wackelt, zum einen weil bei den üblichen
Displays oft an diesem Punkt sehr gespart wurde. Der andere Grund ist,
dass der Strom auf den Signalleitungen auch wieder zurückfließen muss
und bei den langen Leitungen (R+L) gibt es dadurch Spikes auf der Masse
- besonders wenn z.B. viele Datenleitungen synchron den Pegel àndern.
Widerstànde in den Signalleitungen (also kein Abschuss, sondern einfach
einige Ohm an der Quelle in Serie) können dabei auch helfen.

Reinhardt

Ähnliche fragen