Frage zu Mittelwert

21/10/2009 - 17:38 von Christian \(schogix\) Schoger | Report spam
Hi Group
Vielleicht kann mir jemand "weiterhelfen"...
Ich habe eine Tabelle in der in einer Spalte jede Menge Werte (Zahlen)
eingetragen sind. Etwa 56,75,88,68,67,65,91, usw...
Diese Werte stammen aus einer Formel und stellen den Prozentanteil von 195
dar. Da diese Tabelle stàndig erweitert wird habe ich die Formel zur
Berechnung des Prozentwertes weiter "nach unten gezogen" als
Berechnungsgrundlagen vorhanden sind. Excel stellt in diesen Zellen (ohne
Berechnungsgrundlage) dann das Ergebnis 0 dar. Soweit so gut, aber wenn ich
jetzt den Mittelwert dieser Spalte berechnen will, führt das durch die
vielen vorhandenen 0en natürlich zu einem verfàlschten Ergebnis...
Mein Lösungsansatz war etwa folgender =wenn A1:Z1<1;mittelwert A1:Z1 (weiß
jetzt nicht genau ob ich alles richtig aus dem Gedàchtnis abgerufen habe;
man möge mir verzeihen, wenn die Schreibweise der Formel nicht exakt
stimmt;-) ) Diese Vorgangsweise aus der Kombination WENN/MITTELWERT bringt
aber leider keine Änderung :-(
Hat jemand eine Lösung für dieses "Problem"
Danke im voraus
Christian (schogix) Schoger
..
Unterwàsche aus Papier hàtte den Vorteil, daß man der Wàscherei die
verschmutzten Stücke zufaxen könnte.
Piet Klocke
 

Lesen sie die antworten

#1 Alexander Wolff
21/10/2009 - 17:50 | Warnen spam
Als <news: ließ
Christian (schogix) Schoger verlautbaren, evtl. nachfolgend zitiert:

Diese Werte stammen aus einer Formel und stellen den Prozentanteil
von 195 dar. Da diese Tabelle stàndig erweitert wird habe ich die
Formel zur Berechnung des Prozentwertes weiter "nach unten gezogen"
als Berechnungsgrundlagen vorhanden sind. Excel stellt in diesen
Zellen (ohne Berechnungsgrundlage) dann das Ergebnis 0 dar. Soweit so
gut, aber wenn ich jetzt den Mittelwert dieser Spalte berechnen will,
führt das durch die vielen vorhandenen 0en natürlich zu einem



=SUMME(A1:Z1)/SUMMENPRODUKT(--(A1:Z1<>0))
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen