Frage zum Sortieren

20/02/2008 - 22:06 von Lars | Report spam
Hallo NG,

ich bin bzgl. Excel 2003 ein Newbie mit folgendem Problem:
Ich habe mehrere Zellen mit unterschiedlichen Zahlenwerten.
Diese möchte ich dynamisch in eine Liste sortieren, und zwar absteigend.
Beispiel: A1 = 200, A2 = 100, A3 = 300
Liste:
C1 = 300
C2 = 200
C1 = 100
Wenn sich die Werte in A1, 2 oder 3 àndern, muss sich die Liste automatisch
anpasssen.

Wie bekomme ich das hin? Autofilter? Ich benötige eine recht detaillierte
Anleitung!

Dank und Grüße,
Larsmu
 

Lesen sie die antworten

#1 Klaus \Perry\ Pago
20/02/2008 - 22:22 | Warnen spam
Hallo Lars,

"Lars" schrieb im Newsbeitrag
news:
Hallo NG,

ich bin bzgl. Excel 2003 ein Newbie mit folgendem Problem:
Ich habe mehrere Zellen mit unterschiedlichen Zahlenwerten.
Diese möchte ich dynamisch in eine Liste sortieren, und zwar absteigend.
Beispiel: A1 = 200, A2 = 100, A3 = 300
Liste:
C1 = 300
C2 = 200
C1 = 100
Wenn sich die Werte in A1, 2 oder 3 àndern, muss sich die Liste
automatisch anpasssen.

Wie bekomme ich das hin? Autofilter? Ich benötige eine recht detaillierte
Anleitung!



ich schlage folgende Lösung mit einer Matrixformel vor - gib in C1 ein:

=WENN(ZEILE(C1)>ANZAHL2($A$1:$A$40);"";INDEX(A$1:A$40;RECHTS(KGRÖSSTE((MMULT(($A$1:$A$40>MTRANS($A$1:$A$40))*1;ZEILE($1:$40)/ZEILE($1:$40))&TEXT(ZEILE($1:$40);"00"))*1;ZEILE(B1));2)*1))
schliesse die Formel (am besten markieren, kopieren und einfügen, nicht
abtippen) mit der drei-Tasten-Kombination STRG+SHIFT+RETURN ab (sonst klappt
es nicht) und kopiere sie bis max. C40 herunter.

Bei Änderungen der Werte in Spalte A sortieren sich die Werte in C
automatisch.

Gruß
Klaus

Ähnliche fragen