Frage zur CPAN-Suche

07/02/2008 - 16:12 von K. Wittrock | Report spam
Hallo NG,

ich will im CPAN nach einem Modul suchen. Auf search.cpan.org gebe ich tk::pathentry ein und das Auswahlfeld darunter
stelle ich um auf "Modules", weil ich ja nach einem Modul suche. Ich erhalte 871 Treffer. Bei einer spàteren
Wiederholung vergese ich die Umschaltung des Auswahlfelds, lasse es also auf "All" stehen. Jetzt erhalte ich 3 Treffer
(darunter auch das gesuchte Modul).

In meiner Einfalt hatte ich angenommen, dass mit "All" in allen Kategorien gesucht wird. Dann könnte ich aber nicht
weniger Treffer erhalten. Kann mir jemand erklàren, was hier los ist?

Ist hoffentlich nicht allzusehr OT.

Gruß

Klaus

Persönliche Antwort bitte nur an
K<ohne_Punkt_und_Komma>Wittrock<Klammeraffe>web.de
 

Lesen sie die antworten

#1 Frank Seitz
07/02/2008 - 19:50 | Warnen spam
K. Wittrock wrote:

Kann mir jemand erklàren, was hier los ist?



Ich hatte mich auch schon öfter gefragt, wie dieses Suchformular
genau funktioniert. Leider gibt es keine Beschreibung, oder sie
ist so gut versteckt, dass man sie nicht findet.

Im Falle von "All" müssen anscheinend alle Bestandteile
vorkommen (UND-Verknüpfung), im Falle von "Modules" nur
ein Bestandteil (ODER-Verknüpfung). Die Bestandteile deiner
Suche wàren "tk" und "pathentry". Wenn du bei
Einstellung "Modules" nur nach "tk" suchst, erhàltst du
die gleich Treffermenge wie bei "tk::pathentry". Suchst
du nur nach "pathentry", erhàltst du die zwei Treffer
"Tk::PathEntry" und "Tk::PathEntry::Dialog".

Die Site ist wirklich toll, aber die Suche finde ich schwach,
abgesehen davon, dass sie nebulös ist.

Grüße
Frank
Dipl.-Inform. Frank Seitz; http://www.fseitz.de/
Anwendungen für Ihr Internet und Intranet
Tel: 04103/180301; Fax: -02; Industriestr. 31, 22880 Wedel

Ähnliche fragen