Forums Neueste Beiträge
 

Fragen zu MIME-Codierung

13/08/2009 - 16:49 von Thomas Wallutis | Report spam
Hi,

folgende Frage habe ich in einer anderen NG gestellt:

snip--

Hi,

ich habe folgendes Szenario:

- eine Software erzeugt eine EDIFACT Datei
- diese wird in Lotus Notes an eine Mail angehàngt und verschickt
- die Mail landet bei einem Postfix mit SpamAssassin und Virenscanner
- von dort wird sie weitergeleitet an einen Exchange 2007 Server
- greift der User nun per Outlook 2007 auf die Mail zu, ist kein Anhang
zu sehen
- der Fehler scheint bei mindestens zwei Kunden aufzutreten; andere
Empfànger haben dieses Problem (angeblich) nicht
- der Anhang wird, laut Rohtext der Mail, base64-codiert

Leider habe ich keinen direkten Zugriff auf die Original-Mails, nur auf
eine (am Postfix) weitergeleitete Version. Beim Betrachten der Mails
sind mir zwei Dinge aufgefallen, die ich nicht so ganz verstehe:

- die EDIFACT-Datei ist eine Textdatei. Obwohl sie eigentlich angehàngt
werden soll, steht in der Mail


Müsste es dann nicht


lauten?

Faszinierend fand ich auch den mixed/alternative Part (es handelt sich
hierbei um einen kurzen Disclaimer). Der Teil mit dem HTML-Code hat die
folgenden Zeilen am Anfang:


Der Nur-Text-Teil hat die folgenden Zeilen am Anfang:


Was mich hierbei wunderts ist, dass dieser Teil Umlaute enthàlt. Ist das
korrekt?

Leider kenne ich keinen direkten Weg, diese Mails in Outlook abzulegen.
Mit dem Tool Aid4Mail habe ich die Textdatei (umbenannt in .eml) in mein
en Stand-Alone Outlook Client importiert und da war der Anhang korrekt
zu sehen (mit der Endung .txt).

snip--

Ich bin nun auf den folgenden Artikel gestossen:

http://support.microsoft.com/?scid=...4111&x&y=1

Der hat mich nun komplett verwirrt. Ich dachte eigentlich, dass
Bild) innerhalb des Textes angezeigt wird. Diesen Artikel verstehe ich
nun so, dass Outlook das komplett ignoriert und Attachments IMMER
anhàngt, egal was content-disposition sagt. Ist das nicht ein Verstoss
gegen den im Artikel erwàhnten RFC?

Mit freundlichen Grüßen

Thomas Wallutis
 

Lesen sie die antworten

#1 Thomas Wallutis
20/08/2009 - 16:45 | Warnen spam
Hi,

ich habe mir jetzt mal eine Testumgebung mit Exchange und einem Postfix
Server aufgebaut (der sich als überflüssig herausgestellt hat).

Der erneute Versand dieser Mail hat nun nicht geklappt; aber es ging ja
auch einfacher...

Mailtext genommen, Empfànger an meine Testumgebung angepasst, Datei die
Endung .eml gegeben und ins Exchange Pickup-Verzeichnis gegeben.

Ergebnis: Mail wird zugestellt und taucht in Outlook auf... ohne Anhang.

Aber der witzige Teil kommt erst noch: schaue ich mir dieselbe Mail per
Outlook Web Access an, sehe ich den Anhang (und kann ihn auch öffnen).

Hat jemand eine Erklàrung dafür?

Bis denn

Thomas

Ähnliche fragen